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ADuCM320 Support Package
This guide describes the following features of the ADuCM320 CPU support package:

• How to create ADuCM320 projects

• How to open ADuCM320 sample projects

• ADuCM320 specific project properties

• ADuCM320 specific project templates

• Supported ADuCM320 devices
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Creating ADuCM320 Projects

Creating an ADuCM320 C/C++ executable project

To create a new minimal C/C++ executable project:

• Select the File > New > New Project menu item.

• Select the A C/C++ executable for Analog Devices ADuCM320 project template.

• Set the required project name and location directory.

• Click Next.

• If required, change any of the default project settings.

• Click Finish to create the project.

Creating an ADuCM320 library project

To create a new library project:

• Select the File > New > New Project menu item.

• Select the A library for Analog Devices ADuCM320 project template.

• Set the required project name and location directory.

• Click Next.

• If required, change any of the default project settings.

• Click Finish to create the project.

Creating an ADuCM320 externally built executable project

To create a new project that will allow you to debug an existing externally built executable file:

• Select the File > New > New Project menu item.

• Select the An externally built executable for Analog Devices ADuCM320 project template.

• Set the required project name and location directory.

• Click Next.

• Set the Load File project property to point to the executable file you want to download and debug.

• If required, change any of the other default project settings.

• Click Finish to create the project.

Creating an ADuCM320 CrossWorks Tasking Library executable project

To create a new C/C++ executable project configured to use the CrossWorks Tasking Library:

• Select the File > New > New Project menu item.

• Select the A CrossWorks Tasking Library executable for Analog Devices ADuCM320 project template.

• Set the required project name and location directory.

• Click Next.
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• If required, change any of the other default project settings.

• Click Finish to create the project.

Creating an ADuCM320 assembly code only executable project

Please note, this template does not add any C/C++ startup code or libraries and is therefore not suitable for creating

projects that include C/C++ code.

To create a new assembly code only executable project without:

• Select the File > New > New Project menu item.

• Select the An assembly code only executable for Analog Devices ADuCM320 project template.

• Set the required project name and location directory.

• Click Next.

• If required, change any of the other default project settings.

• Click Finish to create the project.
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Opening ADuCM320 Sample Solutions

ADuCM320 Samples Solution

This solution contains general sample projects that run on ADuCM320 devices. To open the ADuCM320 Samples

Solution:

• Select the Tools > Show Installed Packages menu item.

• Select the Analog Devices ADuCM320 CPU Support Package link.

• Select the Samples Solutions > ADuCM320 Samples Solution link.

ADuCM320 CMSIS-DSP Samples Solution

This solution contains sample projects that use the CMSIS-DSP library running on ADuCM320 devices. To open

the ADuCM320 CMSIS-DSP Samples Solution:

• Select the Tools > Show Installed Packages menu item.

• Select the Analog Devices ADuCM320 CPU Support Package link.

• Select the Sample Solutions > ADuCM320 CMSIS-DSP Samples Solution link.
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ADuCM320 Project Properties
Projects creating using the project templates in this support package have the following device specific project

properties:

Heap Size

The heap size is set to be 256 bytes when a project is created. The heap size can be modified using the Heap Size

project property.

Section Placement

You can select the memory configuration you require using the Section Placement project property.

For ADuCM320 projects, the set of placements are:

• Flash - The application runs in internal Flash memory (default).

• Flash Vectors In RAM - The application runs in internal Flash memory and exception vectors are copied to

RAM memory.

• Flash Copy To RAM - The application starts in internal flash and copies itself to run from internal RAM

memory.

• RAM - The application runs from internal RAM memory only.

Stack Sizes

The main stack size is set to be 256 bytes when a project is created.

The process stack size is set to be 0 bytes when a project is created.

The main and process stack sizes can be modified using the Main Stack Size and Process Stack Size project

properties.

To change the location of the stacks, edit the section placement file and place the .stack and .stack_process

sections as required.

Startup From Reset

By default, the application will only startup from power-on/reset in Release configuration. This acts as a safety

net in case you accidently download a program in FLASH during development that crashes and prevents the

debugger from taking control of the target over the debug interface thus rendering the device unusable.

For ADuCM320 projects, the Startup From Reset project property can be set to one of the following:

• No - The application will not startup from reset.
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• Release Only - The application will only startup from reset when built in Release configuration (default).

• Yes - The application will always startup from reset.

Target Processor

Once a project has been created you can target different devices by modifying the Target Processor project

property. See the ADuCM320 Devices section for details on the files, preprocessor definitions and macro

definitions used when a device is selected.
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ADuCM320 Project Templates
The project template system simplifies the creation of new projects with the IDE, it also system makes it easy to

create new projects with a text editor or script. All that needs to be specified is the project name, the support

packages that the project is dependent on, the target processor and the source files you want to add to the

project. For example, create a file called example.hzp with the following contents:

<!DOCTYPE CrossStudio_Project_File>
<solution Name="Example Solution">
  <project Name="Example Project" template_name="ADuCM320_EXE">
    <configuration Name="Common" package_dependencies="ADuCM320" Target="ADuCM320" />
    <folder Name="Source Files">
      <file file_name="file1.c" />
      <file file_name="file2.c" />
    </folder>
  </project>
</solution>

You can also add any other property settings that the project requires such as preprocessor definitions or

include paths using the property save name, for example:

<!DOCTYPE CrossStudio_Project_File>
<solution Name="Example Solution">
  <project Name="Example Project" template_name="ADuCM320_EXE">
    <configuration Name="Common" package_dependencies="ADuCM320" Target="ADuCM320"
 c_preprocessor_definitions="MYDEF1=1;MYDEF2=TWO" c_user_include_directories="$(ProjectDir)/
include1;$(ProjectDir)/include2" />
    <folder Name="Source Files">
      <file file_name="file1.c" />
      <file file_name="file2.c" />
    </folder>
  </project>
</solution>

Available ADuCM320 project templates

Template Name Template Description

ADuCM320_ASM_EXE ADuCM320 Assembly Code Only Executable

ADuCM320_CTL_EXE ADuCM320 CTL Executable

ADuCM320_EXE ADuCM320 C/C++ Executable

ADuCM320_EXT_EXE ADuCM320 Externally Built Executable

ADuCM320_LIB ADuCM320 Library
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ADuCM320 Devices
This package supports the following ADuCM320 devices:

• ADuCM320

• ADuCM320i

• ADuCM322

• ADuCM322i
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ADuCM320
Device Details

CMSIS Header File
$(TargetsDir)/ADuCM320/CMSIS/Device/Include/
ADuCM320.h

CMSIS Include Path $(TargetsDir)/ADuCM320/CMSIS/Device/Include

CMSIS System File
$(TargetsDir)/ADuCM320/CMSIS/Device/Source/
system_ADUCM320.c

Family ADuCM320

Loader File
$(TargetsDir)/ADuCM320/Loader/
ADuCM32x_Series_Loader.elf

Memory Map File
$(TargetsDir)/ADuCM320/XML/
ADuCM320_MemoryMap.xml

Register Definition File
$(TargetsDir)/ADuCM320/XML/
ADuCM320_Registers.xml

Vectors File
$(TargetsDir)/ADuCM320/Source/
ADuCM320_Vectors.s

Preprocessor Definitions

ADuCM320

ARM_MATH_CM3

__ADuCM320_FAMILY

Memory Segments

FLASH 0x00000000 - 0x0003FFFF

RAM 0x20000000 - 0x20007FFF

Project Macros

DeviceIncludePath=$(TargetsDir)/ADuCM320/CMSIS/Device/Include

DeviceHeaderFile=$(TargetsDir)/ADuCM320/CMSIS/Device/Include/ADuCM320.h

DeviceLoaderFile=$(TargetsDir)/ADuCM320/Loader/ADuCM32x_Series_Loader.elf

DeviceRegisterDefinitionFile=$(TargetsDir)/ADuCM320/XML/ADuCM320_Registers.xml

DeviceSystemFile=$(TargetsDir)/ADuCM320/CMSIS/Device/Source/system_ADUCM320.c

DeviceVectorsFile=$(TargetsDir)/ADuCM320/Source/ADuCM320_Vectors.s

DeviceFamily=ADuCM320
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ADuCM320i
Device Details

CMSIS Header File
$(TargetsDir)/ADuCM320/CMSIS/Device/Include/
ADuCM320i.h

CMSIS Include Path $(TargetsDir)/ADuCM320/CMSIS/Device/Include

CMSIS System File
$(TargetsDir)/ADuCM320/CMSIS/Device/Source/
system_ADUCM320I.c

Family ADuCM320

Loader File
$(TargetsDir)/ADuCM320/Loader/
ADuCM32x_Series_Loader.elf

Memory Map File
$(TargetsDir)/ADuCM320/XML/
ADuCM320i_MemoryMap.xml

Register Definition File
$(TargetsDir)/ADuCM320/XML/
ADuCM320i_Registers.xml

Vectors File
$(TargetsDir)/ADuCM320/Source/
ADuCM320i_Vectors.s

Preprocessor Definitions

ADuCM320i

ARM_MATH_CM3

__ADuCM320_FAMILY

Memory Segments

FLASH 0x00000000 - 0x0003FFFF

RAM 0x20000000 - 0x20007FFF

Project Macros

DeviceIncludePath=$(TargetsDir)/ADuCM320/CMSIS/Device/Include

DeviceHeaderFile=$(TargetsDir)/ADuCM320/CMSIS/Device/Include/ADuCM320i.h

DeviceLoaderFile=$(TargetsDir)/ADuCM320/Loader/ADuCM32x_Series_Loader.elf

DeviceRegisterDefinitionFile=$(TargetsDir)/ADuCM320/XML/ADuCM320i_Registers.xml

DeviceSystemFile=$(TargetsDir)/ADuCM320/CMSIS/Device/Source/system_ADUCM320I.c

DeviceVectorsFile=$(TargetsDir)/ADuCM320/Source/ADuCM320i_Vectors.s

DeviceFamily=ADuCM320
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ADuCM322
Device Details

CMSIS Header File
$(TargetsDir)/ADuCM320/CMSIS/Device/Include/
ADuCM322.h

CMSIS Include Path $(TargetsDir)/ADuCM320/CMSIS/Device/Include

CMSIS System File
$(TargetsDir)/ADuCM320/CMSIS/Device/Source/
system_ADUCM322.c

Family ADuCM320

Loader File
$(TargetsDir)/ADuCM320/Loader/
ADuCM32x_Series_Loader.elf

Memory Map File
$(TargetsDir)/ADuCM320/XML/
ADuCM322_MemoryMap.xml

Register Definition File
$(TargetsDir)/ADuCM320/XML/
ADuCM322_Registers.xml

Vectors File
$(TargetsDir)/ADuCM320/Source/
ADuCM322_Vectors.s

Preprocessor Definitions

ADuCM322

ARM_MATH_CM3

__ADuCM320_FAMILY

Memory Segments

FLASH 0x00000000 - 0x0003FFFF

RAM 0x20000000 - 0x20007FFF

Project Macros

DeviceIncludePath=$(TargetsDir)/ADuCM320/CMSIS/Device/Include

DeviceHeaderFile=$(TargetsDir)/ADuCM320/CMSIS/Device/Include/ADuCM322.h

DeviceLoaderFile=$(TargetsDir)/ADuCM320/Loader/ADuCM32x_Series_Loader.elf

DeviceRegisterDefinitionFile=$(TargetsDir)/ADuCM320/XML/ADuCM322_Registers.xml

DeviceSystemFile=$(TargetsDir)/ADuCM320/CMSIS/Device/Source/system_ADUCM322.c

DeviceVectorsFile=$(TargetsDir)/ADuCM320/Source/ADuCM322_Vectors.s

DeviceFamily=ADuCM320
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ADuCM322i
Device Details

CMSIS Header File
$(TargetsDir)/ADuCM320/CMSIS/Device/Include/
ADuCM322.h

CMSIS Include Path $(TargetsDir)/ADuCM320/CMSIS/Device/Include

CMSIS System File
$(TargetsDir)/ADuCM320/CMSIS/Device/Source/
system_ADUCM322.c

Family ADuCM320

Loader File
$(TargetsDir)/ADuCM320/Loader/
ADuCM32x_Series_Loader.elf

Memory Map File
$(TargetsDir)/ADuCM320/XML/
ADuCM322i_MemoryMap.xml

Register Definition File
$(TargetsDir)/ADuCM320/XML/
ADuCM322_Registers.xml

Vectors File
$(TargetsDir)/ADuCM320/Source/
ADuCM322_Vectors.s

Preprocessor Definitions

ADuCM322

ARM_MATH_CM3

__ADuCM320_FAMILY

Memory Segments

FLASH 0x00000000 - 0x0003FFFF

RAM 0x20000000 - 0x20007FFF

Project Macros

DeviceIncludePath=$(TargetsDir)/ADuCM320/CMSIS/Device/Include

DeviceHeaderFile=$(TargetsDir)/ADuCM320/CMSIS/Device/Include/ADuCM322.h

DeviceLoaderFile=$(TargetsDir)/ADuCM320/Loader/ADuCM32x_Series_Loader.elf

DeviceRegisterDefinitionFile=$(TargetsDir)/ADuCM320/XML/ADuCM322_Registers.xml

DeviceSystemFile=$(TargetsDir)/ADuCM320/CMSIS/Device/Source/system_ADUCM322.c

DeviceVectorsFile=$(TargetsDir)/ADuCM320/Source/ADuCM322_Vectors.s

DeviceFamily=ADuCM320
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