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Apollo Support Package
This guide describes the following features of the Apollo CPU support package:

How to create Apollo projects

How to open Apollo sample projects

Apollo specific project properties

Apollo specific project templates

Supported Apollo devices
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Creating Apollo Projects

Creating an Apollo C/C++ executable project

To create a new minimal C/C++ executable project:

Select the File > New > New Project menu item.

Select the A C/C++ executable for Ambiq Micro Apollo project template.

Set the required project name and location directory.

Click Next.

If required, change any of the default project settings.

Click Finish to create the project.

Creating an Apollo library project

To create a new library project:

Select the File > New > New Project menu item.

Select the A library for Ambiq Micro Apollo project template.

Set the required project name and location directory.

Click Next.

If required, change any of the default project settings.

Click Finish to create the project.

Creating an Apollo externally built executable project

To create a new project that will allow you to debug an existing externally built executable file:

Select the File > New > New Project menu item.

Select the An externally built executable for Ambiq Micro Apollo project template.

Set the required project name and location directory.

Click Next.

Set the Load File project property to point to the executable file you want to download and debug.

If required, change any of the other default project settings.

Click Finish to create the project.

Creating an Apollo CrossWorks Tasking Library executable project

To create a new C/C++ executable project configured to use the CrossWorks Tasking Library:

Select the File > New > New Project menu item.

Select the A CrossWorks Tasking Library executable for Ambiq Micro Apollo project template.

Set the required project name and location directory.

Click Next.
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If required, change any of the other default project settings.

Click Finish to create the project.

Creating an Apollo assembly code only executable project

Please note, this template does not add any C/C++ startup code or libraries and is therefore not suitable for creating

projects that include C/C++ code.

To create a new assembly code only executable project without:

Select the File > New > New Project menu item.

Select the An assembly code only executable for Ambiq Micro Apollo project template.

Set the required project name and location directory.

Click Next.

If required, change any of the other default project settings.

Click Finish to create the project.
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Opening Apollo Sample Solutions

Apollo Samples Solution

This solution contains general sample projects that run on Apollo devices. To open the Apollo Samples Solution:

Select the Tools > Show Installed Packages menu item.

Select the Ambiq Micro Apollo CPU Support Package link.

Select the Samples Solutions > Apollo Samples Solution link.

Apollo CMSIS-DSP Samples Solution

This solution contains sample projects that use the CMSIS-DSP library running on Apollo devices. To open the

Apollo CMSIS-DSP Samples Solution:

Select the Tools > Show Installed Packages menu item.

Select the Ambiq Micro Apollo CPU Support Package link.

Select the Sample Solutions > Apollo CMSIS-DSP Samples Solution link.
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Apollo Project Properties
Projects creating using the project templates in this support package have the following device specific project

properties:

Heap Size

The heap size is set to be 256 bytes when a project is created. The heap size can be modified using the Heap Size

project property.

Section Placement

You can select the memory configuration you require using the Section Placement project property.

For Apollo projects, the set of placements are:

Flash - The application runs in internal Flash memory (default).

Flash Vectors In RAM - The application runs in internal Flash memory and exception vectors are copied to

RAM memory.

Flash Copy To RAM - The application starts in internal flash and copies itself to run from internal RAM

memory.

RAM - The application runs from internal RAM memory only.

Stack Sizes

The main stack size is set to be 256 bytes when a project is created.

The process stack size is set to be 0 bytes when a project is created.

The main and process stack sizes can be modified using the Main Stack Size and Process Stack Size project

properties.

To change the location of the stacks, edit the section placement file and place the .stack and .stack_process

sections as required.

Startup From Reset

By default, the application will only startup from power-on/reset in Release configuration. This acts as a safety

net in case you accidently download a program in FLASH during development that crashes and prevents the

debugger from taking control of the target over the debug interface thus rendering the device unusable.

For Apollo projects, the Startup From Reset project property can be set to one of the following:

No - The application will not startup from reset.
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Release Only - The application will only startup from reset when built in Release configuration (default).

Yes - The application will always startup from reset.

Target Processor

Once a project has been created you can target different devices by modifying the Target Processor project

property. See the Apollo Devices section for details on the files, preprocessor definitions and macro definitions

used when a device is selected.
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Apollo Project Templates
The project template system simplifies the creation of new projects with the IDE, it also system makes it easy to

create new projects with a text editor or script. All that needs to be specified is the project name, the support

packages that the project is dependent on, the target processor and the source files you want to add to the

project. For example, create a file called example.hzp with the following contents:

<!DOCTYPE CrossStudio_Project_File>
<solution Name="Example Solution">
  <project Name="Example Project" template_name="Apollo_EXE">
    <configuration Name="Common" package_dependencies="Apollo" Target="AMA3B2KK-KBR" />
    <folder Name="Source Files">
      <file file_name="file1.c" />
      <file file_name="file2.c" />
    </folder>
  </project>
</solution>

You can also add any other property settings that the project requires such as preprocessor definitions or

include paths using the property save name, for example:

<!DOCTYPE CrossStudio_Project_File>
<solution Name="Example Solution">
  <project Name="Example Project" template_name="Apollo_EXE">
    <configuration Name="Common" package_dependencies="Apollo" Target="AMA3B2KK-KBR"
 c_preprocessor_definitions="MYDEF1=1;MYDEF2=TWO" c_user_include_directories="$(ProjectDir)/
include1;$(ProjectDir)/include2" />
    <folder Name="Source Files">
      <file file_name="file1.c" />
      <file file_name="file2.c" />
    </folder>
  </project>
</solution>

Available Apollo project templates

Template Name Template Description

Apollo_ASM_EXE Apollo Assembly Code Only Executable

Apollo_CTL_EXE Apollo CTL Executable

Apollo_EXE Apollo C/C++ Executable

Apollo_EXT_EXE Apollo Externally Built Executable

Apollo_LIB Apollo Library
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Apollo Devices
This package supports the following Apollo devices:

APOLLO512-KBR

APOLLO256-KBR

APOLLO512-KCR

APOLLO256-KCR

AMAPH1KK-KBR

AMAPH1KK-KCR

AMA3B1KK-KBR

AMA3B1KK-KCR

AMA3B2KK-KBR

AMA3B2KK-KCR
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APOLLO512-KBR
Device Details

CMSIS Header File $(TargetsDir)/Apollo/CMSIS/Device/Include/apollo1.h

CMSIS Include Path $(TargetsDir)/Apollo/CMSIS/Device/Include

CMSIS System File
$(TargetsDir)/Apollo/CMSIS/Device/Source/
system_apollo1.c

Family Apollo

Loader File $(TargetsDir)/Apollo/Loader/Apollo_Loader.elf

Memory Map File
$(TargetsDir)/Apollo/XML/APOLLO512-
KBR_MemoryMap.xml

Register Definition File $(TargetsDir)/Apollo/XML/apollo1_Registers.xml

Vectors File $(TargetsDir)/Apollo/Source/apollo1_Vectors.s

Preprocessor Definitions

APOLLO_512

ARM_MATH_CM4

__Apollo_FAMILY

Memory Segments

FLASH 0x00000000 - 0x0007FFFF

RAM 0x10000000 - 0x1000FFFF

Project Macros

DeviceIncludePath=$(TargetsDir)/Apollo/CMSIS/Device/Include

DeviceHeaderFile=$(TargetsDir)/Apollo/CMSIS/Device/Include/apollo1.h

DeviceLoaderFile=$(TargetsDir)/Apollo/Loader/Apollo_Loader.elf

DeviceRegisterDefinitionFile=$(TargetsDir)/Apollo/XML/apollo1_Registers.xml

DeviceSystemFile=$(TargetsDir)/Apollo/CMSIS/Device/Source/system_apollo1.c

DeviceVectorsFile=$(TargetsDir)/Apollo/Source/apollo1_Vectors.s

DeviceFamily=Apollo



Apollo CPU Support Package Guide Apollo Support Package

14

APOLLO256-KBR
Device Details

CMSIS Header File $(TargetsDir)/Apollo/CMSIS/Device/Include/apollo1.h

CMSIS Include Path $(TargetsDir)/Apollo/CMSIS/Device/Include

CMSIS System File
$(TargetsDir)/Apollo/CMSIS/Device/Source/
system_apollo1.c

Family Apollo

Loader File $(TargetsDir)/Apollo/Loader/Apollo_Loader.elf

Memory Map File
$(TargetsDir)/Apollo/XML/APOLLO256-
KBR_MemoryMap.xml

Register Definition File $(TargetsDir)/Apollo/XML/apollo1_Registers.xml

Vectors File $(TargetsDir)/Apollo/Source/apollo1_Vectors.s

Preprocessor Definitions

APOLLO_256

ARM_MATH_CM4

__Apollo_FAMILY

Memory Segments

FLASH 0x00000000 - 0x0003FFFF

RAM 0x10000000 - 0x10007FFF

Project Macros

DeviceIncludePath=$(TargetsDir)/Apollo/CMSIS/Device/Include

DeviceHeaderFile=$(TargetsDir)/Apollo/CMSIS/Device/Include/apollo1.h

DeviceLoaderFile=$(TargetsDir)/Apollo/Loader/Apollo_Loader.elf

DeviceRegisterDefinitionFile=$(TargetsDir)/Apollo/XML/apollo1_Registers.xml

DeviceSystemFile=$(TargetsDir)/Apollo/CMSIS/Device/Source/system_apollo1.c

DeviceVectorsFile=$(TargetsDir)/Apollo/Source/apollo1_Vectors.s

DeviceFamily=Apollo
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APOLLO512-KCR
Device Details

CMSIS Header File $(TargetsDir)/Apollo/CMSIS/Device/Include/apollo1.h

CMSIS Include Path $(TargetsDir)/Apollo/CMSIS/Device/Include

CMSIS System File
$(TargetsDir)/Apollo/CMSIS/Device/Source/
system_apollo1.c

Family Apollo

Loader File $(TargetsDir)/Apollo/Loader/Apollo_Loader.elf

Memory Map File
$(TargetsDir)/Apollo/XML/APOLLO512-
KCR_MemoryMap.xml

Register Definition File $(TargetsDir)/Apollo/XML/apollo1_Registers.xml

Vectors File $(TargetsDir)/Apollo/Source/apollo1_Vectors.s

Preprocessor Definitions

APOLLO_512

ARM_MATH_CM4

__Apollo_FAMILY

Memory Segments

FLASH 0x00000000 - 0x0007FFFF

RAM 0x10000000 - 0x1000FFFF

Project Macros

DeviceIncludePath=$(TargetsDir)/Apollo/CMSIS/Device/Include

DeviceHeaderFile=$(TargetsDir)/Apollo/CMSIS/Device/Include/apollo1.h

DeviceLoaderFile=$(TargetsDir)/Apollo/Loader/Apollo_Loader.elf

DeviceRegisterDefinitionFile=$(TargetsDir)/Apollo/XML/apollo1_Registers.xml

DeviceSystemFile=$(TargetsDir)/Apollo/CMSIS/Device/Source/system_apollo1.c

DeviceVectorsFile=$(TargetsDir)/Apollo/Source/apollo1_Vectors.s

DeviceFamily=Apollo
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APOLLO256-KCR
Device Details

CMSIS Header File $(TargetsDir)/Apollo/CMSIS/Device/Include/apollo1.h

CMSIS Include Path $(TargetsDir)/Apollo/CMSIS/Device/Include

CMSIS System File
$(TargetsDir)/Apollo/CMSIS/Device/Source/
system_apollo1.c

Family Apollo

Loader File $(TargetsDir)/Apollo/Loader/Apollo_Loader.elf

Memory Map File
$(TargetsDir)/Apollo/XML/APOLLO256-
KCR_MemoryMap.xml

Register Definition File $(TargetsDir)/Apollo/XML/apollo1_Registers.xml

Vectors File $(TargetsDir)/Apollo/Source/apollo1_Vectors.s

Preprocessor Definitions

APOLLO_256

ARM_MATH_CM4

__Apollo_FAMILY

Memory Segments

FLASH 0x00000000 - 0x0003FFFF

RAM 0x10000000 - 0x10007FFF

Project Macros

DeviceIncludePath=$(TargetsDir)/Apollo/CMSIS/Device/Include

DeviceHeaderFile=$(TargetsDir)/Apollo/CMSIS/Device/Include/apollo1.h

DeviceLoaderFile=$(TargetsDir)/Apollo/Loader/Apollo_Loader.elf

DeviceRegisterDefinitionFile=$(TargetsDir)/Apollo/XML/apollo1_Registers.xml

DeviceSystemFile=$(TargetsDir)/Apollo/CMSIS/Device/Source/system_apollo1.c

DeviceVectorsFile=$(TargetsDir)/Apollo/Source/apollo1_Vectors.s

DeviceFamily=Apollo
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AMAPH1KK-KBR
Device Details

CMSIS Header File $(TargetsDir)/Apollo/CMSIS/Device/Include/apollo2.h

CMSIS Include Path $(TargetsDir)/Apollo/CMSIS/Device/Include

CMSIS System File
$(TargetsDir)/Apollo/CMSIS/Device/Source/
system_apollo2.c

Family Apollo

Loader File $(TargetsDir)/Apollo/Loader/Apollo2_Loader.elf

Memory Map File
$(TargetsDir)/Apollo/XML/AMAPH1KK-
KBR_MemoryMap.xml

Register Definition File $(TargetsDir)/Apollo/XML/apollo2_Registers.xml

Vectors File $(TargetsDir)/Apollo/Source/apollo2_Vectors.s

Preprocessor Definitions

APOLLO2_1024

ARM_MATH_CM4

__Apollo_FAMILY

Memory Segments

FLASH 0x00000000 - 0x000FFFFF

RAM 0x10000000 - 0x1003FFFF

Project Macros

DeviceIncludePath=$(TargetsDir)/Apollo/CMSIS/Device/Include

DeviceHeaderFile=$(TargetsDir)/Apollo/CMSIS/Device/Include/apollo2.h

DeviceLoaderFile=$(TargetsDir)/Apollo/Loader/Apollo2_Loader.elf

DeviceRegisterDefinitionFile=$(TargetsDir)/Apollo/XML/apollo2_Registers.xml

DeviceSystemFile=$(TargetsDir)/Apollo/CMSIS/Device/Source/system_apollo2.c

DeviceVectorsFile=$(TargetsDir)/Apollo/Source/apollo2_Vectors.s

DeviceFamily=Apollo
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AMAPH1KK-KCR
Device Details

CMSIS Header File $(TargetsDir)/Apollo/CMSIS/Device/Include/apollo2.h

CMSIS Include Path $(TargetsDir)/Apollo/CMSIS/Device/Include

CMSIS System File
$(TargetsDir)/Apollo/CMSIS/Device/Source/
system_apollo2.c

Family Apollo

Loader File $(TargetsDir)/Apollo/Loader/Apollo2_Loader.elf

Memory Map File
$(TargetsDir)/Apollo/XML/AMAPH1KK-
KCR_MemoryMap.xml

Register Definition File $(TargetsDir)/Apollo/XML/apollo2_Registers.xml

Vectors File $(TargetsDir)/Apollo/Source/apollo2_Vectors.s

Preprocessor Definitions

APOLLO2_1024

ARM_MATH_CM4

__Apollo_FAMILY

Memory Segments

FLASH 0x00000000 - 0x000FFFFF

RAM 0x10000000 - 0x1003FFFF

Project Macros

DeviceIncludePath=$(TargetsDir)/Apollo/CMSIS/Device/Include

DeviceHeaderFile=$(TargetsDir)/Apollo/CMSIS/Device/Include/apollo2.h

DeviceLoaderFile=$(TargetsDir)/Apollo/Loader/Apollo2_Loader.elf

DeviceRegisterDefinitionFile=$(TargetsDir)/Apollo/XML/apollo2_Registers.xml

DeviceSystemFile=$(TargetsDir)/Apollo/CMSIS/Device/Source/system_apollo2.c

DeviceVectorsFile=$(TargetsDir)/Apollo/Source/apollo2_Vectors.s

DeviceFamily=Apollo
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AMA3B1KK-KBR
Device Details

CMSIS Header File $(TargetsDir)/Apollo/CMSIS/Device/Include/apollo3.h

CMSIS Include Path $(TargetsDir)/Apollo/CMSIS/Device/Include

CMSIS System File
$(TargetsDir)/Apollo/CMSIS/Device/Source/
system_apollo3.c

Family Apollo

Loader File $(TargetsDir)/Apollo/Loader/Apollo3_Loader.elf

Memory Map File
$(TargetsDir)/Apollo/XML/AMA3B1KK-
KBR_MemoryMap.xml

Register Definition File $(TargetsDir)/Apollo/XML/apollo3_Registers.xml

Vectors File $(TargetsDir)/Apollo/Source/apollo3_Vectors.s

Preprocessor Definitions

APOLLO3_1024

ARM_MATH_CM4

__Apollo_FAMILY

Memory Segments

RAM 0x10000000 - 0x1005FFFF

FLASH 0x0000C000 - 0x000FFFFF

Project Macros

DeviceIncludePath=$(TargetsDir)/Apollo/CMSIS/Device/Include

DeviceHeaderFile=$(TargetsDir)/Apollo/CMSIS/Device/Include/apollo3.h

DeviceLoaderFile=$(TargetsDir)/Apollo/Loader/Apollo3_Loader.elf

DeviceRegisterDefinitionFile=$(TargetsDir)/Apollo/XML/apollo3_Registers.xml

DeviceSystemFile=$(TargetsDir)/Apollo/CMSIS/Device/Source/system_apollo3.c

DeviceVectorsFile=$(TargetsDir)/Apollo/Source/apollo3_Vectors.s

DeviceFamily=Apollo
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AMA3B1KK-KCR
Device Details

CMSIS Header File $(TargetsDir)/Apollo/CMSIS/Device/Include/apollo3.h

CMSIS Include Path $(TargetsDir)/Apollo/CMSIS/Device/Include

CMSIS System File
$(TargetsDir)/Apollo/CMSIS/Device/Source/
system_apollo3.c

Family Apollo

Loader File $(TargetsDir)/Apollo/Loader/Apollo3_Loader.elf

Memory Map File
$(TargetsDir)/Apollo/XML/AMA3B1KK-
KCR_MemoryMap.xml

Register Definition File $(TargetsDir)/Apollo/XML/apollo3_Registers.xml

Vectors File $(TargetsDir)/Apollo/Source/apollo3_Vectors.s

Preprocessor Definitions

APOLLO3_1024

ARM_MATH_CM4

__Apollo_FAMILY

Memory Segments

FLASH 0x0000C000 - 0x000FFFFF

RAM 0x10000000 - 0x1005FFFF

Project Macros

DeviceIncludePath=$(TargetsDir)/Apollo/CMSIS/Device/Include

DeviceHeaderFile=$(TargetsDir)/Apollo/CMSIS/Device/Include/apollo3.h

DeviceLoaderFile=$(TargetsDir)/Apollo/Loader/Apollo3_Loader.elf

DeviceRegisterDefinitionFile=$(TargetsDir)/Apollo/XML/apollo3_Registers.xml

DeviceSystemFile=$(TargetsDir)/Apollo/CMSIS/Device/Source/system_apollo3.c

DeviceVectorsFile=$(TargetsDir)/Apollo/Source/apollo3_Vectors.s

DeviceFamily=Apollo
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AMA3B2KK-KBR
Device Details

CMSIS Header File $(TargetsDir)/Apollo/CMSIS/Device/Include/apollo3p.h

CMSIS Include Path $(TargetsDir)/Apollo/CMSIS/Device/Include

CMSIS System File
$(TargetsDir)/Apollo/CMSIS/Device/Source/
system_apollo3p.c

Family Apollo

Loader File $(TargetsDir)/Apollo/Loader/Apollo3p_Loader.elf

Memory Map File
$(TargetsDir)/Apollo/XML/AMA3B2KK-
KBR_MemoryMap.xml

Register Definition File $(TargetsDir)/Apollo/XML/apollo3p_Registers.xml

Vectors File $(TargetsDir)/Apollo/Source/apollo3p_Vectors.s

Preprocessor Definitions

APOLLO3P_2048

ARM_MATH_CM4

__Apollo_FAMILY

Memory Segments

RAM 0x10000000 - 0x100BFFFF

FLASH 0x0000C000 - 0x001FFFFF

Project Macros

DeviceIncludePath=$(TargetsDir)/Apollo/CMSIS/Device/Include

DeviceHeaderFile=$(TargetsDir)/Apollo/CMSIS/Device/Include/apollo3p.h

DeviceLoaderFile=$(TargetsDir)/Apollo/Loader/Apollo3p_Loader.elf

DeviceRegisterDefinitionFile=$(TargetsDir)/Apollo/XML/apollo3p_Registers.xml

DeviceSystemFile=$(TargetsDir)/Apollo/CMSIS/Device/Source/system_apollo3p.c

DeviceVectorsFile=$(TargetsDir)/Apollo/Source/apollo3p_Vectors.s

DeviceFamily=Apollo
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AMA3B2KK-KCR
Device Details

CMSIS Header File $(TargetsDir)/Apollo/CMSIS/Device/Include/apollo3p.h

CMSIS Include Path $(TargetsDir)/Apollo/CMSIS/Device/Include

CMSIS System File
$(TargetsDir)/Apollo/CMSIS/Device/Source/
system_apollo3p.c

Family Apollo

Loader File $(TargetsDir)/Apollo/Loader/Apollo3p_Loader.elf

Memory Map File
$(TargetsDir)/Apollo/XML/AMA3B2KK-
KCR_MemoryMap.xml

Register Definition File $(TargetsDir)/Apollo/XML/apollo3p_Registers.xml

Vectors File $(TargetsDir)/Apollo/Source/apollo3p_Vectors.s

Preprocessor Definitions

APOLLO3P_2048

ARM_MATH_CM4

__Apollo_FAMILY

Memory Segments

RAM 0x10000000 - 0x100BFFFF

FLASH 0x0000C000 - 0x001FFFFF

Project Macros

DeviceIncludePath=$(TargetsDir)/Apollo/CMSIS/Device/Include

DeviceHeaderFile=$(TargetsDir)/Apollo/CMSIS/Device/Include/apollo3p.h

DeviceLoaderFile=$(TargetsDir)/Apollo/Loader/Apollo3p_Loader.elf

DeviceRegisterDefinitionFile=$(TargetsDir)/Apollo/XML/apollo3p_Registers.xml

DeviceSystemFile=$(TargetsDir)/Apollo/CMSIS/Device/Source/system_apollo3p.c

DeviceVectorsFile=$(TargetsDir)/Apollo/Source/apollo3p_Vectors.s

DeviceFamily=Apollo
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