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GD32E23x Support Package
This guide describes the following features of the GD32E23x CPU support package:

How to create GD32E23x projects

How to open GD32E23x sample projects

GD32E23x specific project properties

GD32E23x specific project templates

Supported GD32E23x devices
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Creating GD32E23x Projects

Creating an GD32E23x C/C++ executable project

To create a new minimal C/C++ executable project:

Select the File > New > New Project menu item.

Select the A C/C++ executable for GigaDevice GD32E23x project template.

Set the required project name and location directory.

Click Next.

If required, change any of the default project settings.

Click Finish to create the project.

Creating an GD32E23x library project

To create a new library project:

Select the File > New > New Project menu item.

Select the A library for GigaDevice GD32E23x project template.

Set the required project name and location directory.

Click Next.

If required, change any of the default project settings.

Click Finish to create the project.

Creating an GD32E23x externally built executable project

To create a new project that will allow you to debug an existing externally built executable file:

Select the File > New > New Project menu item.

Select the An externally built executable for GigaDevice GD32E23x project template.

Set the required project name and location directory.

Click Next.

Set the Load File project property to point to the executable file you want to download and debug.

If required, change any of the other default project settings.

Click Finish to create the project.

Creating an GD32E23x CrossWorks Tasking Library executable project

To create a new C/C++ executable project configured to use the CrossWorks Tasking Library:

Select the File > New > New Project menu item.

Select the A CrossWorks Tasking Library executable for GigaDevice GD32E23x project template.

Set the required project name and location directory.

Click Next.
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If required, change any of the other default project settings.

Click Finish to create the project.

Creating an GD32E23x assembly code only executable project

Please note, this template does not add any C/C++ startup code or libraries and is therefore not suitable for creating

projects that include C/C++ code.

To create a new assembly code only executable project without:

Select the File > New > New Project menu item.

Select the An assembly code only executable for GigaDevice GD32E23x project template.

Set the required project name and location directory.

Click Next.

If required, change any of the other default project settings.

Click Finish to create the project.
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Opening GD32E23x Sample Solutions

GD32E23x Samples Solution

This solution contains general sample projects that run on GD32E23x devices. To open the GD32E23x Samples

Solution:

Select the Tools > Show Installed Packages menu item.

Select the GigaDevice GD32E23x CPU Support Package link.

Select the Samples Solutions > GD32E23x Samples Solution link.

GD32E23x CMSIS-DSP Samples Solution

This solution contains sample projects that use the CMSIS-DSP library running on GD32E23x devices. To open

the GD32E23x CMSIS-DSP Samples Solution:

Select the Tools > Show Installed Packages menu item.

Select the GigaDevice GD32E23x CPU Support Package link.

Select the Sample Solutions > GD32E23x CMSIS-DSP Samples Solution link.
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GD32E23x Project Properties
Projects creating using the project templates in this support package have the following device specific project

properties:

Heap Size

The heap size is set to be 256 bytes when a project is created. The heap size can be modified using the Heap Size

project property.

Section Placement

You can select the memory configuration you require using the Section Placement project property.

For GD32E23x projects, the set of placements are:

Flash - The application runs in internal Flash memory (default).

Flash Vectors In RAM - The application runs in internal Flash memory and exception vectors are copied to

RAM memory.

Flash Copy To RAM - The application starts in internal flash and copies itself to run from internal RAM

memory.

RAM - The application runs from internal RAM memory only.

Stack Sizes

The main stack size is set to be 256 bytes when a project is created.

The process stack size is set to be 0 bytes when a project is created.

The main and process stack sizes can be modified using the Main Stack Size and Process Stack Size project

properties.

To change the location of the stacks, edit the section placement file and place the .stack and .stack_process

sections as required.

Startup From Reset

By default, the application will only startup from power-on/reset in Release configuration. This acts as a safety

net in case you accidently download a program in FLASH during development that crashes and prevents the

debugger from taking control of the target over the debug interface thus rendering the device unusable.

For GD32E23x projects, the Startup From Reset project property can be set to one of the following:

No - The application will not startup from reset.
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Release Only - The application will only startup from reset when built in Release configuration (default).

Yes - The application will always startup from reset.

Target Processor

Once a project has been created you can target different devices by modifying the Target Processor project

property. See the GD32E23x Devices section for details on the files, preprocessor definitions and macro

definitions used when a device is selected.
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GD32E23x Project Templates
The project template system simplifies the creation of new projects with the IDE, it also system makes it easy to

create new projects with a text editor or script. All that needs to be specified is the project name, the support

packages that the project is dependent on, the target processor and the source files you want to add to the

project. For example, create a file called example.hzp with the following contents:

<!DOCTYPE CrossStudio_Project_File>
<solution Name="Example Solution">
  <project Name="Example Project" template_name="GD32E23x_EXE">
    <configuration Name="Common" package_dependencies="GD32E23x" Target="GD32E230C8" />
    <folder Name="Source Files">
      <file file_name="file1.c" />
      <file file_name="file2.c" />
    </folder>
  </project>
</solution>

You can also add any other property settings that the project requires such as preprocessor definitions or

include paths using the property save name, for example:

<!DOCTYPE CrossStudio_Project_File>
<solution Name="Example Solution">
  <project Name="Example Project" template_name="GD32E23x_EXE">
    <configuration Name="Common" package_dependencies="GD32E23x" Target="GD32E230C8"
 c_preprocessor_definitions="MYDEF1=1;MYDEF2=TWO" c_user_include_directories="$(ProjectDir)/
include1;$(ProjectDir)/include2" />
    <folder Name="Source Files">
      <file file_name="file1.c" />
      <file file_name="file2.c" />
    </folder>
  </project>
</solution>

Available GD32E23x project templates

Template Name Template Description

GD32E23x_ASM_EXE GD32E23x Assembly Code Only Executable

GD32E23x_CTL_EXE GD32E23x CTL Executable

GD32E23x_EXE GD32E23x C/C++ Executable

GD32E23x_EXT_EXE GD32E23x Externally Built Executable

GD32E23x_LIB GD32E23x Library
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GD32E23x Devices
This package supports the following GD32E23x devices:

GD32E230 Family

GD32E231 Family
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GD32E230 Family
GD32E230C8

GD32E230C6

GD32E230C4

GD32E230K8

GD32E230K6

GD32E230K4

GD32E230G8

GD32E230G6

GD32E230G4

GD32E230F8

GD32E230F6

GD32E230F4
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GD32E230C8
Device Details

CMSIS Header File
$(TargetsDir)/GD32E23x/CMSIS/Device/Include/
gd32e23x.h

CMSIS Include Path $(TargetsDir)/GD32E23x/CMSIS/Device/Include

CMSIS System File
$(TargetsDir)/GD32E23x/CMSIS/Device/Source/
system_gd32e23x.c

Family GD32E23x

Sub Family GD32E230

Loader File $(TargetsDir)/GD32E23x/Loader/GD32E23x_Loader.elf

Memory Map File
$(TargetsDir)/GD32E23x/XML/
GD32E230C8_MemoryMap.xml

Register Definition File
$(TargetsDir)/GD32E23x/XML/
GD32E230_Registers.xml

Vectors File $(TargetsDir)/GD32E23x/Source/GD32E230_Vectors.s

Preprocessor Definitions

ARM_MATH_ARMV8MBL

GD32E230

__GD32E230_SUBFAMILY

__GD32E23x_FAMILY

Memory Segments

FLASH 0x08000000 - 0x0800FFFF

RAM 0x20000000 - 0x20001FFF

Project Macros

DeviceIncludePath=$(TargetsDir)/GD32E23x/CMSIS/Device/Include

DeviceHeaderFile=$(TargetsDir)/GD32E23x/CMSIS/Device/Include/gd32e23x.h

DeviceLoaderFile=$(TargetsDir)/GD32E23x/Loader/GD32E23x_Loader.elf

DeviceRegisterDefinitionFile=$(TargetsDir)/GD32E23x/XML/GD32E230_Registers.xml

DeviceSystemFile=$(TargetsDir)/GD32E23x/CMSIS/Device/Source/system_gd32e23x.c

DeviceVectorsFile=$(TargetsDir)/GD32E23x/Source/GD32E230_Vectors.s

DeviceFamily=GD32E23x

DeviceSubFamily=GD32E230
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GD32E230C6
Device Details

CMSIS Header File
$(TargetsDir)/GD32E23x/CMSIS/Device/Include/
gd32e23x.h

CMSIS Include Path $(TargetsDir)/GD32E23x/CMSIS/Device/Include

CMSIS System File
$(TargetsDir)/GD32E23x/CMSIS/Device/Source/
system_gd32e23x.c

Family GD32E23x

Sub Family GD32E230

Loader File $(TargetsDir)/GD32E23x/Loader/GD32E23x_Loader.elf

Memory Map File
$(TargetsDir)/GD32E23x/XML/
GD32E230C6_MemoryMap.xml

Register Definition File
$(TargetsDir)/GD32E23x/XML/
GD32E230_Registers.xml

Vectors File $(TargetsDir)/GD32E23x/Source/GD32E230_Vectors.s

Preprocessor Definitions

ARM_MATH_ARMV8MBL

GD32E230

__GD32E230_SUBFAMILY

__GD32E23x_FAMILY

Memory Segments

FLASH 0x08000000 - 0x08007FFF

RAM 0x20000000 - 0x200017FF

Project Macros

DeviceIncludePath=$(TargetsDir)/GD32E23x/CMSIS/Device/Include

DeviceHeaderFile=$(TargetsDir)/GD32E23x/CMSIS/Device/Include/gd32e23x.h

DeviceLoaderFile=$(TargetsDir)/GD32E23x/Loader/GD32E23x_Loader.elf

DeviceRegisterDefinitionFile=$(TargetsDir)/GD32E23x/XML/GD32E230_Registers.xml

DeviceSystemFile=$(TargetsDir)/GD32E23x/CMSIS/Device/Source/system_gd32e23x.c

DeviceVectorsFile=$(TargetsDir)/GD32E23x/Source/GD32E230_Vectors.s

DeviceFamily=GD32E23x

DeviceSubFamily=GD32E230
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GD32E230C4
Device Details

CMSIS Header File
$(TargetsDir)/GD32E23x/CMSIS/Device/Include/
gd32e23x.h

CMSIS Include Path $(TargetsDir)/GD32E23x/CMSIS/Device/Include

CMSIS System File
$(TargetsDir)/GD32E23x/CMSIS/Device/Source/
system_gd32e23x.c

Family GD32E23x

Sub Family GD32E230

Loader File $(TargetsDir)/GD32E23x/Loader/GD32E23x_Loader.elf

Memory Map File
$(TargetsDir)/GD32E23x/XML/
GD32E230C4_MemoryMap.xml

Register Definition File
$(TargetsDir)/GD32E23x/XML/
GD32E230_Registers.xml

Vectors File $(TargetsDir)/GD32E23x/Source/GD32E230_Vectors.s

Preprocessor Definitions

ARM_MATH_ARMV8MBL

GD32E230

__GD32E230_SUBFAMILY

__GD32E23x_FAMILY

Memory Segments

FLASH 0x08000000 - 0x08003FFF

RAM 0x20000000 - 0x20000FFF

Project Macros

DeviceIncludePath=$(TargetsDir)/GD32E23x/CMSIS/Device/Include

DeviceHeaderFile=$(TargetsDir)/GD32E23x/CMSIS/Device/Include/gd32e23x.h

DeviceLoaderFile=$(TargetsDir)/GD32E23x/Loader/GD32E23x_Loader.elf

DeviceRegisterDefinitionFile=$(TargetsDir)/GD32E23x/XML/GD32E230_Registers.xml

DeviceSystemFile=$(TargetsDir)/GD32E23x/CMSIS/Device/Source/system_gd32e23x.c

DeviceVectorsFile=$(TargetsDir)/GD32E23x/Source/GD32E230_Vectors.s

DeviceFamily=GD32E23x

DeviceSubFamily=GD32E230
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GD32E230K8
Device Details

CMSIS Header File
$(TargetsDir)/GD32E23x/CMSIS/Device/Include/
gd32e23x.h

CMSIS Include Path $(TargetsDir)/GD32E23x/CMSIS/Device/Include

CMSIS System File
$(TargetsDir)/GD32E23x/CMSIS/Device/Source/
system_gd32e23x.c

Family GD32E23x

Sub Family GD32E230

Loader File $(TargetsDir)/GD32E23x/Loader/GD32E23x_Loader.elf

Memory Map File
$(TargetsDir)/GD32E23x/XML/
GD32E230K8_MemoryMap.xml

Register Definition File
$(TargetsDir)/GD32E23x/XML/
GD32E230_Registers.xml

Vectors File $(TargetsDir)/GD32E23x/Source/GD32E230_Vectors.s

Preprocessor Definitions

ARM_MATH_ARMV8MBL

GD32E230

__GD32E230_SUBFAMILY

__GD32E23x_FAMILY

Memory Segments

FLASH 0x08000000 - 0x0800FFFF

RAM 0x20000000 - 0x20001FFF

Project Macros

DeviceIncludePath=$(TargetsDir)/GD32E23x/CMSIS/Device/Include

DeviceHeaderFile=$(TargetsDir)/GD32E23x/CMSIS/Device/Include/gd32e23x.h

DeviceLoaderFile=$(TargetsDir)/GD32E23x/Loader/GD32E23x_Loader.elf

DeviceRegisterDefinitionFile=$(TargetsDir)/GD32E23x/XML/GD32E230_Registers.xml

DeviceSystemFile=$(TargetsDir)/GD32E23x/CMSIS/Device/Source/system_gd32e23x.c

DeviceVectorsFile=$(TargetsDir)/GD32E23x/Source/GD32E230_Vectors.s

DeviceFamily=GD32E23x

DeviceSubFamily=GD32E230
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GD32E230K6
Device Details

CMSIS Header File
$(TargetsDir)/GD32E23x/CMSIS/Device/Include/
gd32e23x.h

CMSIS Include Path $(TargetsDir)/GD32E23x/CMSIS/Device/Include

CMSIS System File
$(TargetsDir)/GD32E23x/CMSIS/Device/Source/
system_gd32e23x.c

Family GD32E23x

Sub Family GD32E230

Loader File $(TargetsDir)/GD32E23x/Loader/GD32E23x_Loader.elf

Memory Map File
$(TargetsDir)/GD32E23x/XML/
GD32E230K6_MemoryMap.xml

Register Definition File
$(TargetsDir)/GD32E23x/XML/
GD32E230_Registers.xml

Vectors File $(TargetsDir)/GD32E23x/Source/GD32E230_Vectors.s

Preprocessor Definitions

ARM_MATH_ARMV8MBL

GD32E230

__GD32E230_SUBFAMILY

__GD32E23x_FAMILY

Memory Segments

FLASH 0x08000000 - 0x08007FFF

RAM 0x20000000 - 0x200017FF

Project Macros

DeviceIncludePath=$(TargetsDir)/GD32E23x/CMSIS/Device/Include

DeviceHeaderFile=$(TargetsDir)/GD32E23x/CMSIS/Device/Include/gd32e23x.h

DeviceLoaderFile=$(TargetsDir)/GD32E23x/Loader/GD32E23x_Loader.elf

DeviceRegisterDefinitionFile=$(TargetsDir)/GD32E23x/XML/GD32E230_Registers.xml

DeviceSystemFile=$(TargetsDir)/GD32E23x/CMSIS/Device/Source/system_gd32e23x.c

DeviceVectorsFile=$(TargetsDir)/GD32E23x/Source/GD32E230_Vectors.s

DeviceFamily=GD32E23x

DeviceSubFamily=GD32E230
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GD32E230K4
Device Details

CMSIS Header File
$(TargetsDir)/GD32E23x/CMSIS/Device/Include/
gd32e23x.h

CMSIS Include Path $(TargetsDir)/GD32E23x/CMSIS/Device/Include

CMSIS System File
$(TargetsDir)/GD32E23x/CMSIS/Device/Source/
system_gd32e23x.c

Family GD32E23x

Sub Family GD32E230

Loader File $(TargetsDir)/GD32E23x/Loader/GD32E23x_Loader.elf

Memory Map File
$(TargetsDir)/GD32E23x/XML/
GD32E230K4_MemoryMap.xml

Register Definition File
$(TargetsDir)/GD32E23x/XML/
GD32E230_Registers.xml

Vectors File $(TargetsDir)/GD32E23x/Source/GD32E230_Vectors.s

Preprocessor Definitions

ARM_MATH_ARMV8MBL

GD32E230

__GD32E230_SUBFAMILY

__GD32E23x_FAMILY

Memory Segments

FLASH 0x08000000 - 0x08003FFF

RAM 0x20000000 - 0x20000FFF

Project Macros

DeviceIncludePath=$(TargetsDir)/GD32E23x/CMSIS/Device/Include

DeviceHeaderFile=$(TargetsDir)/GD32E23x/CMSIS/Device/Include/gd32e23x.h

DeviceLoaderFile=$(TargetsDir)/GD32E23x/Loader/GD32E23x_Loader.elf

DeviceRegisterDefinitionFile=$(TargetsDir)/GD32E23x/XML/GD32E230_Registers.xml

DeviceSystemFile=$(TargetsDir)/GD32E23x/CMSIS/Device/Source/system_gd32e23x.c

DeviceVectorsFile=$(TargetsDir)/GD32E23x/Source/GD32E230_Vectors.s

DeviceFamily=GD32E23x

DeviceSubFamily=GD32E230
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GD32E230G8
Device Details

CMSIS Header File
$(TargetsDir)/GD32E23x/CMSIS/Device/Include/
gd32e23x.h

CMSIS Include Path $(TargetsDir)/GD32E23x/CMSIS/Device/Include

CMSIS System File
$(TargetsDir)/GD32E23x/CMSIS/Device/Source/
system_gd32e23x.c

Family GD32E23x

Sub Family GD32E230

Loader File $(TargetsDir)/GD32E23x/Loader/GD32E23x_Loader.elf

Memory Map File
$(TargetsDir)/GD32E23x/XML/
GD32E230G8_MemoryMap.xml

Register Definition File
$(TargetsDir)/GD32E23x/XML/
GD32E230_Registers.xml

Vectors File $(TargetsDir)/GD32E23x/Source/GD32E230_Vectors.s

Preprocessor Definitions

ARM_MATH_ARMV8MBL

GD32E230

__GD32E230_SUBFAMILY

__GD32E23x_FAMILY

Memory Segments

FLASH 0x08000000 - 0x0800FFFF

RAM 0x20000000 - 0x20001FFF

Project Macros

DeviceIncludePath=$(TargetsDir)/GD32E23x/CMSIS/Device/Include

DeviceHeaderFile=$(TargetsDir)/GD32E23x/CMSIS/Device/Include/gd32e23x.h

DeviceLoaderFile=$(TargetsDir)/GD32E23x/Loader/GD32E23x_Loader.elf

DeviceRegisterDefinitionFile=$(TargetsDir)/GD32E23x/XML/GD32E230_Registers.xml

DeviceSystemFile=$(TargetsDir)/GD32E23x/CMSIS/Device/Source/system_gd32e23x.c

DeviceVectorsFile=$(TargetsDir)/GD32E23x/Source/GD32E230_Vectors.s

DeviceFamily=GD32E23x

DeviceSubFamily=GD32E230
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GD32E230G6
Device Details

CMSIS Header File
$(TargetsDir)/GD32E23x/CMSIS/Device/Include/
gd32e23x.h

CMSIS Include Path $(TargetsDir)/GD32E23x/CMSIS/Device/Include

CMSIS System File
$(TargetsDir)/GD32E23x/CMSIS/Device/Source/
system_gd32e23x.c

Family GD32E23x

Sub Family GD32E230

Loader File $(TargetsDir)/GD32E23x/Loader/GD32E23x_Loader.elf

Memory Map File
$(TargetsDir)/GD32E23x/XML/
GD32E230G6_MemoryMap.xml

Register Definition File
$(TargetsDir)/GD32E23x/XML/
GD32E230_Registers.xml

Vectors File $(TargetsDir)/GD32E23x/Source/GD32E230_Vectors.s

Preprocessor Definitions

ARM_MATH_ARMV8MBL

GD32E230

__GD32E230_SUBFAMILY

__GD32E23x_FAMILY

Memory Segments

FLASH 0x08000000 - 0x08007FFF

RAM 0x20000000 - 0x200017FF

Project Macros

DeviceIncludePath=$(TargetsDir)/GD32E23x/CMSIS/Device/Include

DeviceHeaderFile=$(TargetsDir)/GD32E23x/CMSIS/Device/Include/gd32e23x.h

DeviceLoaderFile=$(TargetsDir)/GD32E23x/Loader/GD32E23x_Loader.elf

DeviceRegisterDefinitionFile=$(TargetsDir)/GD32E23x/XML/GD32E230_Registers.xml

DeviceSystemFile=$(TargetsDir)/GD32E23x/CMSIS/Device/Source/system_gd32e23x.c

DeviceVectorsFile=$(TargetsDir)/GD32E23x/Source/GD32E230_Vectors.s

DeviceFamily=GD32E23x

DeviceSubFamily=GD32E230
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GD32E230G4
Device Details

CMSIS Header File
$(TargetsDir)/GD32E23x/CMSIS/Device/Include/
gd32e23x.h

CMSIS Include Path $(TargetsDir)/GD32E23x/CMSIS/Device/Include

CMSIS System File
$(TargetsDir)/GD32E23x/CMSIS/Device/Source/
system_gd32e23x.c

Family GD32E23x

Sub Family GD32E230

Loader File $(TargetsDir)/GD32E23x/Loader/GD32E23x_Loader.elf

Memory Map File
$(TargetsDir)/GD32E23x/XML/
GD32E230G4_MemoryMap.xml

Register Definition File
$(TargetsDir)/GD32E23x/XML/
GD32E230_Registers.xml

Vectors File $(TargetsDir)/GD32E23x/Source/GD32E230_Vectors.s

Preprocessor Definitions

ARM_MATH_ARMV8MBL

GD32E230

__GD32E230_SUBFAMILY

__GD32E23x_FAMILY

Memory Segments

FLASH 0x08000000 - 0x08003FFF

RAM 0x20000000 - 0x20000FFF

Project Macros

DeviceIncludePath=$(TargetsDir)/GD32E23x/CMSIS/Device/Include

DeviceHeaderFile=$(TargetsDir)/GD32E23x/CMSIS/Device/Include/gd32e23x.h

DeviceLoaderFile=$(TargetsDir)/GD32E23x/Loader/GD32E23x_Loader.elf

DeviceRegisterDefinitionFile=$(TargetsDir)/GD32E23x/XML/GD32E230_Registers.xml

DeviceSystemFile=$(TargetsDir)/GD32E23x/CMSIS/Device/Source/system_gd32e23x.c

DeviceVectorsFile=$(TargetsDir)/GD32E23x/Source/GD32E230_Vectors.s

DeviceFamily=GD32E23x

DeviceSubFamily=GD32E230
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GD32E230F8
Device Details

CMSIS Header File
$(TargetsDir)/GD32E23x/CMSIS/Device/Include/
gd32e23x.h

CMSIS Include Path $(TargetsDir)/GD32E23x/CMSIS/Device/Include

CMSIS System File
$(TargetsDir)/GD32E23x/CMSIS/Device/Source/
system_gd32e23x.c

Family GD32E23x

Sub Family GD32E230

Loader File $(TargetsDir)/GD32E23x/Loader/GD32E23x_Loader.elf

Memory Map File
$(TargetsDir)/GD32E23x/XML/
GD32E230F8_MemoryMap.xml

Register Definition File
$(TargetsDir)/GD32E23x/XML/
GD32E230_Registers.xml

Vectors File $(TargetsDir)/GD32E23x/Source/GD32E230_Vectors.s

Preprocessor Definitions

ARM_MATH_ARMV8MBL

GD32E230

__GD32E230_SUBFAMILY

__GD32E23x_FAMILY

Memory Segments

FLASH 0x08000000 - 0x0800FFFF

RAM 0x20000000 - 0x20001FFF

Project Macros

DeviceIncludePath=$(TargetsDir)/GD32E23x/CMSIS/Device/Include

DeviceHeaderFile=$(TargetsDir)/GD32E23x/CMSIS/Device/Include/gd32e23x.h

DeviceLoaderFile=$(TargetsDir)/GD32E23x/Loader/GD32E23x_Loader.elf

DeviceRegisterDefinitionFile=$(TargetsDir)/GD32E23x/XML/GD32E230_Registers.xml

DeviceSystemFile=$(TargetsDir)/GD32E23x/CMSIS/Device/Source/system_gd32e23x.c

DeviceVectorsFile=$(TargetsDir)/GD32E23x/Source/GD32E230_Vectors.s

DeviceFamily=GD32E23x

DeviceSubFamily=GD32E230
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GD32E230F6
Device Details

CMSIS Header File
$(TargetsDir)/GD32E23x/CMSIS/Device/Include/
gd32e23x.h

CMSIS Include Path $(TargetsDir)/GD32E23x/CMSIS/Device/Include

CMSIS System File
$(TargetsDir)/GD32E23x/CMSIS/Device/Source/
system_gd32e23x.c

Family GD32E23x

Sub Family GD32E230

Loader File $(TargetsDir)/GD32E23x/Loader/GD32E23x_Loader.elf

Memory Map File
$(TargetsDir)/GD32E23x/XML/
GD32E230F6_MemoryMap.xml

Register Definition File
$(TargetsDir)/GD32E23x/XML/
GD32E230_Registers.xml

Vectors File $(TargetsDir)/GD32E23x/Source/GD32E230_Vectors.s

Preprocessor Definitions

ARM_MATH_ARMV8MBL

GD32E230

__GD32E230_SUBFAMILY

__GD32E23x_FAMILY

Memory Segments

FLASH 0x08000000 - 0x08007FFF

RAM 0x20000000 - 0x200017FF

Project Macros

DeviceIncludePath=$(TargetsDir)/GD32E23x/CMSIS/Device/Include

DeviceHeaderFile=$(TargetsDir)/GD32E23x/CMSIS/Device/Include/gd32e23x.h

DeviceLoaderFile=$(TargetsDir)/GD32E23x/Loader/GD32E23x_Loader.elf

DeviceRegisterDefinitionFile=$(TargetsDir)/GD32E23x/XML/GD32E230_Registers.xml

DeviceSystemFile=$(TargetsDir)/GD32E23x/CMSIS/Device/Source/system_gd32e23x.c

DeviceVectorsFile=$(TargetsDir)/GD32E23x/Source/GD32E230_Vectors.s

DeviceFamily=GD32E23x

DeviceSubFamily=GD32E230
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GD32E230F4
Device Details

CMSIS Header File
$(TargetsDir)/GD32E23x/CMSIS/Device/Include/
gd32e23x.h

CMSIS Include Path $(TargetsDir)/GD32E23x/CMSIS/Device/Include

CMSIS System File
$(TargetsDir)/GD32E23x/CMSIS/Device/Source/
system_gd32e23x.c

Family GD32E23x

Sub Family GD32E230

Loader File $(TargetsDir)/GD32E23x/Loader/GD32E23x_Loader.elf

Memory Map File
$(TargetsDir)/GD32E23x/XML/
GD32E230F4_MemoryMap.xml

Register Definition File
$(TargetsDir)/GD32E23x/XML/
GD32E230_Registers.xml

Vectors File $(TargetsDir)/GD32E23x/Source/GD32E230_Vectors.s

Preprocessor Definitions

ARM_MATH_ARMV8MBL

GD32E230

__GD32E230_SUBFAMILY

__GD32E23x_FAMILY

Memory Segments

FLASH 0x08000000 - 0x08003FFF

RAM 0x20000000 - 0x20000FFF

Project Macros

DeviceIncludePath=$(TargetsDir)/GD32E23x/CMSIS/Device/Include

DeviceHeaderFile=$(TargetsDir)/GD32E23x/CMSIS/Device/Include/gd32e23x.h

DeviceLoaderFile=$(TargetsDir)/GD32E23x/Loader/GD32E23x_Loader.elf

DeviceRegisterDefinitionFile=$(TargetsDir)/GD32E23x/XML/GD32E230_Registers.xml

DeviceSystemFile=$(TargetsDir)/GD32E23x/CMSIS/Device/Source/system_gd32e23x.c

DeviceVectorsFile=$(TargetsDir)/GD32E23x/Source/GD32E230_Vectors.s

DeviceFamily=GD32E23x

DeviceSubFamily=GD32E230
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GD32E231 Family
GD32E231C4

GD32E231C6

GD32E231C8
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GD32E231C4
Device Details

CMSIS Header File
$(TargetsDir)/GD32E23x/CMSIS/Device/Include/
gd32e23x.h

CMSIS Include Path $(TargetsDir)/GD32E23x/CMSIS/Device/Include

CMSIS System File
$(TargetsDir)/GD32E23x/CMSIS/Device/Source/
system_gd32e23x.c

Family GD32E23x

Sub Family GD32E231

Loader File $(TargetsDir)/GD32E23x/Loader/GD32E23x_Loader.elf

Memory Map File
$(TargetsDir)/GD32E23x/XML/
GD32E231C4_MemoryMap.xml

Register Definition File
$(TargetsDir)/GD32E23x/XML/
GD32E231_Registers.xml

Vectors File $(TargetsDir)/GD32E23x/Source/GD32E231_Vectors.s

Preprocessor Definitions

ARM_MATH_ARMV8MBL

GD32E231

__GD32E231_SUBFAMILY

__GD32E23x_FAMILY

Memory Segments

FLASH 0x08000000 - 0x08003FFF

RAM 0x20000000 - 0x20000FFF

Project Macros

DeviceIncludePath=$(TargetsDir)/GD32E23x/CMSIS/Device/Include

DeviceHeaderFile=$(TargetsDir)/GD32E23x/CMSIS/Device/Include/gd32e23x.h

DeviceLoaderFile=$(TargetsDir)/GD32E23x/Loader/GD32E23x_Loader.elf

DeviceRegisterDefinitionFile=$(TargetsDir)/GD32E23x/XML/GD32E231_Registers.xml

DeviceSystemFile=$(TargetsDir)/GD32E23x/CMSIS/Device/Source/system_gd32e23x.c

DeviceVectorsFile=$(TargetsDir)/GD32E23x/Source/GD32E231_Vectors.s

DeviceFamily=GD32E23x

DeviceSubFamily=GD32E231
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GD32E231C6
Device Details

CMSIS Header File
$(TargetsDir)/GD32E23x/CMSIS/Device/Include/
gd32e23x.h

CMSIS Include Path $(TargetsDir)/GD32E23x/CMSIS/Device/Include

CMSIS System File
$(TargetsDir)/GD32E23x/CMSIS/Device/Source/
system_gd32e23x.c

Family GD32E23x

Sub Family GD32E231

Loader File $(TargetsDir)/GD32E23x/Loader/GD32E23x_Loader.elf

Memory Map File
$(TargetsDir)/GD32E23x/XML/
GD32E231C6_MemoryMap.xml

Register Definition File
$(TargetsDir)/GD32E23x/XML/
GD32E231_Registers.xml

Vectors File $(TargetsDir)/GD32E23x/Source/GD32E231_Vectors.s

Preprocessor Definitions

ARM_MATH_ARMV8MBL

GD32E231

__GD32E231_SUBFAMILY

__GD32E23x_FAMILY

Memory Segments

FLASH 0x08000000 - 0x08007FFF

RAM 0x20000000 - 0x200017FF

Project Macros

DeviceIncludePath=$(TargetsDir)/GD32E23x/CMSIS/Device/Include

DeviceHeaderFile=$(TargetsDir)/GD32E23x/CMSIS/Device/Include/gd32e23x.h

DeviceLoaderFile=$(TargetsDir)/GD32E23x/Loader/GD32E23x_Loader.elf

DeviceRegisterDefinitionFile=$(TargetsDir)/GD32E23x/XML/GD32E231_Registers.xml

DeviceSystemFile=$(TargetsDir)/GD32E23x/CMSIS/Device/Source/system_gd32e23x.c

DeviceVectorsFile=$(TargetsDir)/GD32E23x/Source/GD32E231_Vectors.s

DeviceFamily=GD32E23x

DeviceSubFamily=GD32E231
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GD32E231C8
Device Details

CMSIS Header File
$(TargetsDir)/GD32E23x/CMSIS/Device/Include/
gd32e23x.h

CMSIS Include Path $(TargetsDir)/GD32E23x/CMSIS/Device/Include

CMSIS System File
$(TargetsDir)/GD32E23x/CMSIS/Device/Source/
system_gd32e23x.c

Family GD32E23x

Sub Family GD32E231

Loader File $(TargetsDir)/GD32E23x/Loader/GD32E23x_Loader.elf

Memory Map File
$(TargetsDir)/GD32E23x/XML/
GD32E231C8_MemoryMap.xml

Register Definition File
$(TargetsDir)/GD32E23x/XML/
GD32E231_Registers.xml

Vectors File $(TargetsDir)/GD32E23x/Source/GD32E231_Vectors.s

Preprocessor Definitions

ARM_MATH_ARMV8MBL

GD32E231

__GD32E231_SUBFAMILY

__GD32E23x_FAMILY

Memory Segments

FLASH 0x08000000 - 0x0800FFFF

RAM 0x20000000 - 0x20001FFF

Project Macros

DeviceIncludePath=$(TargetsDir)/GD32E23x/CMSIS/Device/Include

DeviceHeaderFile=$(TargetsDir)/GD32E23x/CMSIS/Device/Include/gd32e23x.h

DeviceLoaderFile=$(TargetsDir)/GD32E23x/Loader/GD32E23x_Loader.elf

DeviceRegisterDefinitionFile=$(TargetsDir)/GD32E23x/XML/GD32E231_Registers.xml

DeviceSystemFile=$(TargetsDir)/GD32E23x/CMSIS/Device/Source/system_gd32e23x.c

DeviceVectorsFile=$(TargetsDir)/GD32E23x/Source/GD32E231_Vectors.s

DeviceFamily=GD32E23x

DeviceSubFamily=GD32E231
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