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LPC1200 Support Package
This guide describes the following features of the LPC1200 CPU support package:

How to create LPC1200 projects

How to open LPC1200 sample projects

LPC1200 specific project properties

LPC1200 specific project templates

Supported LPC1200 devices
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Creating LPC1200 Projects

Creating an LPC1200 C/C++ executable project

To create a new minimal C/C++ executable project:

Select the File > New > New Project menu item.

Select the A C/C++ executable for NXP LPC1200 project template.

Set the required project name and location directory.

Click Next.

If required, change any of the default project settings.

Click Finish to create the project.

Creating an LPC1200 library project

To create a new library project:

Select the File > New > New Project menu item.

Select the A library for NXP LPC1200 project template.

Set the required project name and location directory.

Click Next.

If required, change any of the default project settings.

Click Finish to create the project.

Creating an LPC1200 externally built executable project

To create a new project that will allow you to debug an existing externally built executable file:

Select the File > New > New Project menu item.

Select the An externally built executable for NXP LPC1200 project template.

Set the required project name and location directory.

Click Next.

Set the Load File project property to point to the executable file you want to download and debug.

If required, change any of the other default project settings.

Click Finish to create the project.

Creating an LPC1200 CrossWorks Tasking Library executable project

To create a new C/C++ executable project configured to use the CrossWorks Tasking Library:

Select the File > New > New Project menu item.

Select the A CrossWorks Tasking Library executable for NXP LPC1200 project template.

Set the required project name and location directory.

Click Next.
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If required, change any of the other default project settings.

Click Finish to create the project.

Creating an LPC1200 assembly code only executable project

Please note, this template does not add any C/C++ startup code or libraries and is therefore not suitable for creating

projects that include C/C++ code.

To create a new assembly code only executable project without:

Select the File > New > New Project menu item.

Select the An assembly code only executable for NXP LPC1200 project template.

Set the required project name and location directory.

Click Next.

If required, change any of the other default project settings.

Click Finish to create the project.



LPC1200 CPU Support Package Guide LPC1200 Support Package

8

Opening LPC1200 Sample Solutions

LPC1200 Samples Solution

This solution contains general sample projects that run on LPC1200 devices. To open the LPC1200 Samples

Solution:

Select the Tools > Show Installed Packages menu item.

Select the NXP LPC1200 CPU Support Package link.

Select the Samples Solutions > LPC1200 Samples Solution link.

LPC1200 CMSIS-DSP Samples Solution

This solution contains sample projects that use the CMSIS-DSP library running on LPC1200 devices. To open the

LPC1200 CMSIS-DSP Samples Solution:

Select the Tools > Show Installed Packages menu item.

Select the NXP LPC1200 CPU Support Package link.

Select the Sample Solutions > LPC1200 CMSIS-DSP Samples Solution link.
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LPC1200 Project Properties
Projects creating using the project templates in this support package have the following device specific project

properties:

Heap Size

The heap size is set to be 256 bytes when a project is created. The heap size can be modified using the Heap Size

project property.

Section Placement

You can select the memory configuration you require using the Section Placement project property.

For LPC1200 projects, the set of placements are:

Flash - The application runs in internal Flash memory (default).

Flash Vectors In RAM - The application runs in internal Flash memory and exception vectors are copied to

RAM memory.

Flash Copy To RAM - The application starts in internal flash and copies itself to run from internal RAM

memory.

RAM - The application runs from internal RAM memory only.

Stack Sizes

The main stack size is set to be 256 bytes when a project is created.

The process stack size is set to be 0 bytes when a project is created.

The main and process stack sizes can be modified using the Main Stack Size and Process Stack Size project

properties.

To change the location of the stacks, edit the section placement file and place the .stack and .stack_process

sections as required.

Startup From Reset

By default, the application will only startup from power-on/reset in Release configuration. This acts as a safety

net in case you accidently download a program in FLASH during development that crashes and prevents the

debugger from taking control of the target over the debug interface thus rendering the device unusable.

For LPC1200 projects, the Startup From Reset project property can be set to one of the following:

No - The application will not startup from reset.
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Release Only - The application will only startup from reset when built in Release configuration (default).

Yes - The application will always startup from reset.

Target Processor

Once a project has been created you can target different devices by modifying the Target Processor project

property. See the LPC1200 Devices section for details on the files, preprocessor definitions and macro

definitions used when a device is selected.
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LPC1200 Project Templates
The project template system simplifies the creation of new projects with the IDE, it also system makes it easy to

create new projects with a text editor or script. All that needs to be specified is the project name, the support

packages that the project is dependent on, the target processor and the source files you want to add to the

project. For example, create a file called example.hzp with the following contents:

<!DOCTYPE CrossStudio_Project_File>
<solution Name="Example Solution">
  <project Name="Example Project" template_name="LPC1200_EXE">
    <configuration Name="Common" package_dependencies="LPC1200" Target="LPC1227FBD64/301" />
    <folder Name="Source Files">
      <file file_name="file1.c" />
      <file file_name="file2.c" />
    </folder>
  </project>
</solution>

You can also add any other property settings that the project requires such as preprocessor definitions or

include paths using the property save name, for example:

<!DOCTYPE CrossStudio_Project_File>
<solution Name="Example Solution">
  <project Name="Example Project" template_name="LPC1200_EXE">
    <configuration Name="Common" package_dependencies="LPC1200" Target="LPC1227FBD64/301"
 c_preprocessor_definitions="MYDEF1=1;MYDEF2=TWO" c_user_include_directories="$(ProjectDir)/
include1;$(ProjectDir)/include2" />
    <folder Name="Source Files">
      <file file_name="file1.c" />
      <file file_name="file2.c" />
    </folder>
  </project>
</solution>

Available LPC1200 project templates

Template Name Template Description

LPC1200_ASM_EXE LPC1200 Assembly Code Only Executable

LPC1200_CTL_EXE LPC1200 CTL Executable

LPC1200_EXE LPC1200 C/C++ Executable

LPC1200_EXT_EXE LPC1200 Externally Built Executable

LPC1200_LIB LPC1200 Library
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LPC1200 Devices
This package supports the following LPC1200 devices:

LPC122x Family
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LPC122x Family
LPC1227FBD64/301

LPC1227FBD48/301

LPC1226FBD64/301

LPC1226FBD48/301

LPC1225FBD64/321

LPC1225FBD64/301

LPC1225FBD48/321

LPC1225FBD48/301

LPC1224FBD64/121

LPC1224FBD64/101

LPC1224FBD48/121

LPC1224FBD48/101
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LPC1227FBD64/301
Device Details

CMSIS Header File
$(TargetsDir)/LPC1200/CMSIS/Device/Include/
LPC12xx/LPC122x.h

CMSIS Include Path $(TargetsDir)/LPC1200/CMSIS/Device/Include/LPC12xx

CMSIS System File
$(TargetsDir)/LPC1200/CMSIS/Device/Source/
system_LPC122x.c

Family LPC1200

Sub Family LPC122x

Loader File $(TargetsDir)/LPC1200/Loader/LPC122x_Loader.elf

Memory Map File
$(TargetsDir)/LPC1200/XML/
LPC1227FBD64_301_MemoryMap.xml

Register Definition File $(TargetsDir)/LPC1200/XML/LPC122x_Registers.xml

Vectors File $(TargetsDir)/LPC1200/Source/LPC122x_Vectors.s

Preprocessor Definitions

ARM_MATH_CM0

LPC1227FBD64_301_DEVICE

__LPC1200_FAMILY

__LPC1227FBD64_301__

__LPC122x_SUBFAMILY

Memory Segments

FLASH 0x00000000 - 0x0001FFFF

RAM 0x10000000 - 0x10001FFF

Project Macros

DeviceIncludePath=$(TargetsDir)/LPC1200/CMSIS/Device/Include/LPC12xx

DeviceHeaderFile=$(TargetsDir)/LPC1200/CMSIS/Device/Include/LPC12xx/LPC122x.h

DeviceLoaderFile=$(TargetsDir)/LPC1200/Loader/LPC122x_Loader.elf

DeviceRegisterDefinitionFile=$(TargetsDir)/LPC1200/XML/LPC122x_Registers.xml

DeviceSystemFile=$(TargetsDir)/LPC1200/CMSIS/Device/Source/system_LPC122x.c

DeviceVectorsFile=$(TargetsDir)/LPC1200/Source/LPC122x_Vectors.s

DeviceFamily=LPC1200

DeviceSubFamily=LPC122x
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LPC1227FBD48/301
Device Details

CMSIS Header File
$(TargetsDir)/LPC1200/CMSIS/Device/Include/
LPC12xx/LPC122x.h

CMSIS Include Path $(TargetsDir)/LPC1200/CMSIS/Device/Include/LPC12xx

CMSIS System File
$(TargetsDir)/LPC1200/CMSIS/Device/Source/
system_LPC122x.c

Family LPC1200

Sub Family LPC122x

Loader File $(TargetsDir)/LPC1200/Loader/LPC122x_Loader.elf

Memory Map File
$(TargetsDir)/LPC1200/XML/
LPC1227FBD48_301_MemoryMap.xml

Register Definition File $(TargetsDir)/LPC1200/XML/LPC122x_Registers.xml

Vectors File $(TargetsDir)/LPC1200/Source/LPC122x_Vectors.s

Preprocessor Definitions

ARM_MATH_CM0

LPC1227FBD48_301_DEVICE

__LPC1200_FAMILY

__LPC1227FBD48_301__

__LPC122x_SUBFAMILY

Memory Segments

FLASH 0x00000000 - 0x0001FFFF

RAM 0x10000000 - 0x10001FFF

Project Macros

DeviceIncludePath=$(TargetsDir)/LPC1200/CMSIS/Device/Include/LPC12xx

DeviceHeaderFile=$(TargetsDir)/LPC1200/CMSIS/Device/Include/LPC12xx/LPC122x.h

DeviceLoaderFile=$(TargetsDir)/LPC1200/Loader/LPC122x_Loader.elf

DeviceRegisterDefinitionFile=$(TargetsDir)/LPC1200/XML/LPC122x_Registers.xml

DeviceSystemFile=$(TargetsDir)/LPC1200/CMSIS/Device/Source/system_LPC122x.c

DeviceVectorsFile=$(TargetsDir)/LPC1200/Source/LPC122x_Vectors.s

DeviceFamily=LPC1200

DeviceSubFamily=LPC122x
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LPC1226FBD64/301
Device Details

CMSIS Header File
$(TargetsDir)/LPC1200/CMSIS/Device/Include/
LPC12xx/LPC122x.h

CMSIS Include Path $(TargetsDir)/LPC1200/CMSIS/Device/Include/LPC12xx

CMSIS System File
$(TargetsDir)/LPC1200/CMSIS/Device/Source/
system_LPC122x.c

Family LPC1200

Sub Family LPC122x

Loader File $(TargetsDir)/LPC1200/Loader/LPC122x_Loader.elf

Memory Map File
$(TargetsDir)/LPC1200/XML/
LPC1226FBD64_301_MemoryMap.xml

Register Definition File $(TargetsDir)/LPC1200/XML/LPC122x_Registers.xml

Vectors File $(TargetsDir)/LPC1200/Source/LPC122x_Vectors.s

Preprocessor Definitions

ARM_MATH_CM0

LPC1226FBD64_301_DEVICE

__LPC1200_FAMILY

__LPC1226FBD64_301__

__LPC122x_SUBFAMILY

Memory Segments

FLASH 0x00000000 - 0x00017FFF

RAM 0x10000000 - 0x10001FFF

Project Macros

DeviceIncludePath=$(TargetsDir)/LPC1200/CMSIS/Device/Include/LPC12xx

DeviceHeaderFile=$(TargetsDir)/LPC1200/CMSIS/Device/Include/LPC12xx/LPC122x.h

DeviceLoaderFile=$(TargetsDir)/LPC1200/Loader/LPC122x_Loader.elf

DeviceRegisterDefinitionFile=$(TargetsDir)/LPC1200/XML/LPC122x_Registers.xml

DeviceSystemFile=$(TargetsDir)/LPC1200/CMSIS/Device/Source/system_LPC122x.c

DeviceVectorsFile=$(TargetsDir)/LPC1200/Source/LPC122x_Vectors.s

DeviceFamily=LPC1200

DeviceSubFamily=LPC122x
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LPC1226FBD48/301
Device Details

CMSIS Header File
$(TargetsDir)/LPC1200/CMSIS/Device/Include/
LPC12xx/LPC122x.h

CMSIS Include Path $(TargetsDir)/LPC1200/CMSIS/Device/Include/LPC12xx

CMSIS System File
$(TargetsDir)/LPC1200/CMSIS/Device/Source/
system_LPC122x.c

Family LPC1200

Sub Family LPC122x

Loader File $(TargetsDir)/LPC1200/Loader/LPC122x_Loader.elf

Memory Map File
$(TargetsDir)/LPC1200/XML/
LPC1226FBD48_301_MemoryMap.xml

Register Definition File $(TargetsDir)/LPC1200/XML/LPC122x_Registers.xml

Vectors File $(TargetsDir)/LPC1200/Source/LPC122x_Vectors.s

Preprocessor Definitions

ARM_MATH_CM0

LPC1226FBD48_301_DEVICE

__LPC1200_FAMILY

__LPC1226FBD48_301__

__LPC122x_SUBFAMILY

Memory Segments

FLASH 0x00000000 - 0x00017FFF

RAM 0x10000000 - 0x10001FFF

Project Macros

DeviceIncludePath=$(TargetsDir)/LPC1200/CMSIS/Device/Include/LPC12xx

DeviceHeaderFile=$(TargetsDir)/LPC1200/CMSIS/Device/Include/LPC12xx/LPC122x.h

DeviceLoaderFile=$(TargetsDir)/LPC1200/Loader/LPC122x_Loader.elf

DeviceRegisterDefinitionFile=$(TargetsDir)/LPC1200/XML/LPC122x_Registers.xml

DeviceSystemFile=$(TargetsDir)/LPC1200/CMSIS/Device/Source/system_LPC122x.c

DeviceVectorsFile=$(TargetsDir)/LPC1200/Source/LPC122x_Vectors.s

DeviceFamily=LPC1200

DeviceSubFamily=LPC122x
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LPC1225FBD64/321
Device Details

CMSIS Header File
$(TargetsDir)/LPC1200/CMSIS/Device/Include/
LPC12xx/LPC122x.h

CMSIS Include Path $(TargetsDir)/LPC1200/CMSIS/Device/Include/LPC12xx

CMSIS System File
$(TargetsDir)/LPC1200/CMSIS/Device/Source/
system_LPC122x.c

Family LPC1200

Sub Family LPC122x

Loader File $(TargetsDir)/LPC1200/Loader/LPC122x_Loader.elf

Memory Map File
$(TargetsDir)/LPC1200/XML/
LPC1225FBD64_321_MemoryMap.xml

Register Definition File $(TargetsDir)/LPC1200/XML/LPC122x_Registers.xml

Vectors File $(TargetsDir)/LPC1200/Source/LPC122x_Vectors.s

Preprocessor Definitions

ARM_MATH_CM0

LPC1225FBD64_321_DEVICE

__LPC1200_FAMILY

__LPC1225FBD64_321__

__LPC122x_SUBFAMILY

Memory Segments

FLASH 0x00000000 - 0x00013FFF

RAM 0x10000000 - 0x10001FFF

Project Macros

DeviceIncludePath=$(TargetsDir)/LPC1200/CMSIS/Device/Include/LPC12xx

DeviceHeaderFile=$(TargetsDir)/LPC1200/CMSIS/Device/Include/LPC12xx/LPC122x.h

DeviceLoaderFile=$(TargetsDir)/LPC1200/Loader/LPC122x_Loader.elf

DeviceRegisterDefinitionFile=$(TargetsDir)/LPC1200/XML/LPC122x_Registers.xml

DeviceSystemFile=$(TargetsDir)/LPC1200/CMSIS/Device/Source/system_LPC122x.c

DeviceVectorsFile=$(TargetsDir)/LPC1200/Source/LPC122x_Vectors.s

DeviceFamily=LPC1200

DeviceSubFamily=LPC122x
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LPC1225FBD64/301
Device Details

CMSIS Header File
$(TargetsDir)/LPC1200/CMSIS/Device/Include/
LPC12xx/LPC122x.h

CMSIS Include Path $(TargetsDir)/LPC1200/CMSIS/Device/Include/LPC12xx

CMSIS System File
$(TargetsDir)/LPC1200/CMSIS/Device/Source/
system_LPC122x.c

Family LPC1200

Sub Family LPC122x

Loader File $(TargetsDir)/LPC1200/Loader/LPC122x_Loader.elf

Memory Map File
$(TargetsDir)/LPC1200/XML/
LPC1225FBD64_301_MemoryMap.xml

Register Definition File $(TargetsDir)/LPC1200/XML/LPC122x_Registers.xml

Vectors File $(TargetsDir)/LPC1200/Source/LPC122x_Vectors.s

Preprocessor Definitions

ARM_MATH_CM0

LPC1225FBD64_301_DEVICE

__LPC1200_FAMILY

__LPC1225FBD64_301__

__LPC122x_SUBFAMILY

Memory Segments

FLASH 0x00000000 - 0x0000FFFF

RAM 0x10000000 - 0x10001FFF

Project Macros

DeviceIncludePath=$(TargetsDir)/LPC1200/CMSIS/Device/Include/LPC12xx

DeviceHeaderFile=$(TargetsDir)/LPC1200/CMSIS/Device/Include/LPC12xx/LPC122x.h

DeviceLoaderFile=$(TargetsDir)/LPC1200/Loader/LPC122x_Loader.elf

DeviceRegisterDefinitionFile=$(TargetsDir)/LPC1200/XML/LPC122x_Registers.xml

DeviceSystemFile=$(TargetsDir)/LPC1200/CMSIS/Device/Source/system_LPC122x.c

DeviceVectorsFile=$(TargetsDir)/LPC1200/Source/LPC122x_Vectors.s

DeviceFamily=LPC1200

DeviceSubFamily=LPC122x
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LPC1225FBD48/321
Device Details

CMSIS Header File
$(TargetsDir)/LPC1200/CMSIS/Device/Include/
LPC12xx/LPC122x.h

CMSIS Include Path $(TargetsDir)/LPC1200/CMSIS/Device/Include/LPC12xx

CMSIS System File
$(TargetsDir)/LPC1200/CMSIS/Device/Source/
system_LPC122x.c

Family LPC1200

Sub Family LPC122x

Loader File $(TargetsDir)/LPC1200/Loader/LPC122x_Loader.elf

Memory Map File
$(TargetsDir)/LPC1200/XML/
LPC1225FBD48_321_MemoryMap.xml

Register Definition File $(TargetsDir)/LPC1200/XML/LPC122x_Registers.xml

Vectors File $(TargetsDir)/LPC1200/Source/LPC122x_Vectors.s

Preprocessor Definitions

ARM_MATH_CM0

LPC1225FBD48_321_DEVICE

__LPC1200_FAMILY

__LPC1225FBD48_321__

__LPC122x_SUBFAMILY

Memory Segments

FLASH 0x00000000 - 0x00013FFF

RAM 0x10000000 - 0x10001FFF

Project Macros

DeviceIncludePath=$(TargetsDir)/LPC1200/CMSIS/Device/Include/LPC12xx

DeviceHeaderFile=$(TargetsDir)/LPC1200/CMSIS/Device/Include/LPC12xx/LPC122x.h

DeviceLoaderFile=$(TargetsDir)/LPC1200/Loader/LPC122x_Loader.elf

DeviceRegisterDefinitionFile=$(TargetsDir)/LPC1200/XML/LPC122x_Registers.xml

DeviceSystemFile=$(TargetsDir)/LPC1200/CMSIS/Device/Source/system_LPC122x.c

DeviceVectorsFile=$(TargetsDir)/LPC1200/Source/LPC122x_Vectors.s

DeviceFamily=LPC1200

DeviceSubFamily=LPC122x
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LPC1225FBD48/301
Device Details

CMSIS Header File
$(TargetsDir)/LPC1200/CMSIS/Device/Include/
LPC12xx/LPC122x.h

CMSIS Include Path $(TargetsDir)/LPC1200/CMSIS/Device/Include/LPC12xx

CMSIS System File
$(TargetsDir)/LPC1200/CMSIS/Device/Source/
system_LPC122x.c

Family LPC1200

Sub Family LPC122x

Loader File $(TargetsDir)/LPC1200/Loader/LPC122x_Loader.elf

Memory Map File
$(TargetsDir)/LPC1200/XML/
LPC1225FBD48_301_MemoryMap.xml

Register Definition File $(TargetsDir)/LPC1200/XML/LPC122x_Registers.xml

Vectors File $(TargetsDir)/LPC1200/Source/LPC122x_Vectors.s

Preprocessor Definitions

ARM_MATH_CM0

LPC1225FBD48_301_DEVICE

__LPC1200_FAMILY

__LPC1225FBD48_301__

__LPC122x_SUBFAMILY

Memory Segments

FLASH 0x00000000 - 0x0000FFFF

RAM 0x10000000 - 0x10001FFF

Project Macros

DeviceIncludePath=$(TargetsDir)/LPC1200/CMSIS/Device/Include/LPC12xx

DeviceHeaderFile=$(TargetsDir)/LPC1200/CMSIS/Device/Include/LPC12xx/LPC122x.h

DeviceLoaderFile=$(TargetsDir)/LPC1200/Loader/LPC122x_Loader.elf

DeviceRegisterDefinitionFile=$(TargetsDir)/LPC1200/XML/LPC122x_Registers.xml

DeviceSystemFile=$(TargetsDir)/LPC1200/CMSIS/Device/Source/system_LPC122x.c

DeviceVectorsFile=$(TargetsDir)/LPC1200/Source/LPC122x_Vectors.s

DeviceFamily=LPC1200

DeviceSubFamily=LPC122x
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LPC1224FBD64/121
Device Details

CMSIS Header File
$(TargetsDir)/LPC1200/CMSIS/Device/Include/
LPC12xx/LPC122x.h

CMSIS Include Path $(TargetsDir)/LPC1200/CMSIS/Device/Include/LPC12xx

CMSIS System File
$(TargetsDir)/LPC1200/CMSIS/Device/Source/
system_LPC122x.c

Family LPC1200

Sub Family LPC122x

Loader File $(TargetsDir)/LPC1200/Loader/LPC122x_Loader.elf

Memory Map File
$(TargetsDir)/LPC1200/XML/
LPC1224FBD64_121_MemoryMap.xml

Register Definition File $(TargetsDir)/LPC1200/XML/LPC122x_Registers.xml

Vectors File $(TargetsDir)/LPC1200/Source/LPC122x_Vectors.s

Preprocessor Definitions

ARM_MATH_CM0

LPC1224FBD64_121_DEVICE

__LPC1200_FAMILY

__LPC1224FBD64_121__

__LPC122x_SUBFAMILY

Memory Segments

FLASH 0x00000000 - 0x0000BFFF

RAM 0x10000000 - 0x10000FFF

Project Macros

DeviceIncludePath=$(TargetsDir)/LPC1200/CMSIS/Device/Include/LPC12xx

DeviceHeaderFile=$(TargetsDir)/LPC1200/CMSIS/Device/Include/LPC12xx/LPC122x.h

DeviceLoaderFile=$(TargetsDir)/LPC1200/Loader/LPC122x_Loader.elf

DeviceRegisterDefinitionFile=$(TargetsDir)/LPC1200/XML/LPC122x_Registers.xml

DeviceSystemFile=$(TargetsDir)/LPC1200/CMSIS/Device/Source/system_LPC122x.c

DeviceVectorsFile=$(TargetsDir)/LPC1200/Source/LPC122x_Vectors.s

DeviceFamily=LPC1200

DeviceSubFamily=LPC122x
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LPC1224FBD64/101
Device Details

CMSIS Header File
$(TargetsDir)/LPC1200/CMSIS/Device/Include/
LPC12xx/LPC122x.h

CMSIS Include Path $(TargetsDir)/LPC1200/CMSIS/Device/Include/LPC12xx

CMSIS System File
$(TargetsDir)/LPC1200/CMSIS/Device/Source/
system_LPC122x.c

Family LPC1200

Sub Family LPC122x

Loader File $(TargetsDir)/LPC1200/Loader/LPC122x_Loader.elf

Memory Map File
$(TargetsDir)/LPC1200/XML/
LPC1224FBD64_101_MemoryMap.xml

Register Definition File $(TargetsDir)/LPC1200/XML/LPC122x_Registers.xml

Vectors File $(TargetsDir)/LPC1200/Source/LPC122x_Vectors.s

Preprocessor Definitions

ARM_MATH_CM0

LPC1224FBD64_101_DEVICE

__LPC1200_FAMILY

__LPC1224FBD64_101__

__LPC122x_SUBFAMILY

Memory Segments

FLASH 0x00000000 - 0x00007FFF

RAM 0x10000000 - 0x10000FFF

Project Macros

DeviceIncludePath=$(TargetsDir)/LPC1200/CMSIS/Device/Include/LPC12xx

DeviceHeaderFile=$(TargetsDir)/LPC1200/CMSIS/Device/Include/LPC12xx/LPC122x.h

DeviceLoaderFile=$(TargetsDir)/LPC1200/Loader/LPC122x_Loader.elf

DeviceRegisterDefinitionFile=$(TargetsDir)/LPC1200/XML/LPC122x_Registers.xml

DeviceSystemFile=$(TargetsDir)/LPC1200/CMSIS/Device/Source/system_LPC122x.c

DeviceVectorsFile=$(TargetsDir)/LPC1200/Source/LPC122x_Vectors.s

DeviceFamily=LPC1200

DeviceSubFamily=LPC122x
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LPC1224FBD48/121
Device Details

CMSIS Header File
$(TargetsDir)/LPC1200/CMSIS/Device/Include/
LPC12xx/LPC122x.h

CMSIS Include Path $(TargetsDir)/LPC1200/CMSIS/Device/Include/LPC12xx

CMSIS System File
$(TargetsDir)/LPC1200/CMSIS/Device/Source/
system_LPC122x.c

Family LPC1200

Sub Family LPC122x

Loader File $(TargetsDir)/LPC1200/Loader/LPC122x_Loader.elf

Memory Map File
$(TargetsDir)/LPC1200/XML/
LPC1224FBD48_121_MemoryMap.xml

Register Definition File $(TargetsDir)/LPC1200/XML/LPC122x_Registers.xml

Vectors File $(TargetsDir)/LPC1200/Source/LPC122x_Vectors.s

Preprocessor Definitions

ARM_MATH_CM0

LPC1224FBD48_121_DEVICE

__LPC1200_FAMILY

__LPC1224FBD48_121__

__LPC122x_SUBFAMILY

Memory Segments

FLASH 0x00000000 - 0x0000BFFF

RAM 0x10000000 - 0x10000FFF

Project Macros

DeviceIncludePath=$(TargetsDir)/LPC1200/CMSIS/Device/Include/LPC12xx

DeviceHeaderFile=$(TargetsDir)/LPC1200/CMSIS/Device/Include/LPC12xx/LPC122x.h

DeviceLoaderFile=$(TargetsDir)/LPC1200/Loader/LPC122x_Loader.elf

DeviceRegisterDefinitionFile=$(TargetsDir)/LPC1200/XML/LPC122x_Registers.xml

DeviceSystemFile=$(TargetsDir)/LPC1200/CMSIS/Device/Source/system_LPC122x.c

DeviceVectorsFile=$(TargetsDir)/LPC1200/Source/LPC122x_Vectors.s

DeviceFamily=LPC1200

DeviceSubFamily=LPC122x
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LPC1224FBD48/101
Device Details

CMSIS Header File
$(TargetsDir)/LPC1200/CMSIS/Device/Include/
LPC12xx/LPC122x.h

CMSIS Include Path $(TargetsDir)/LPC1200/CMSIS/Device/Include/LPC12xx

CMSIS System File
$(TargetsDir)/LPC1200/CMSIS/Device/Source/
system_LPC122x.c

Family LPC1200

Sub Family LPC122x

Loader File $(TargetsDir)/LPC1200/Loader/LPC122x_Loader.elf

Memory Map File
$(TargetsDir)/LPC1200/XML/
LPC1224FBD48_101_MemoryMap.xml

Register Definition File $(TargetsDir)/LPC1200/XML/LPC122x_Registers.xml

Vectors File $(TargetsDir)/LPC1200/Source/LPC122x_Vectors.s

Preprocessor Definitions

ARM_MATH_CM0

LPC1224FBD48_101_DEVICE

__LPC1200_FAMILY

__LPC1224FBD48_101__

__LPC122x_SUBFAMILY

Memory Segments

FLASH 0x00000000 - 0x00007FFF

RAM 0x10000000 - 0x10000FFF

Project Macros

DeviceIncludePath=$(TargetsDir)/LPC1200/CMSIS/Device/Include/LPC12xx

DeviceHeaderFile=$(TargetsDir)/LPC1200/CMSIS/Device/Include/LPC12xx/LPC122x.h

DeviceLoaderFile=$(TargetsDir)/LPC1200/Loader/LPC122x_Loader.elf

DeviceRegisterDefinitionFile=$(TargetsDir)/LPC1200/XML/LPC122x_Registers.xml

DeviceSystemFile=$(TargetsDir)/LPC1200/CMSIS/Device/Source/system_LPC122x.c

DeviceVectorsFile=$(TargetsDir)/LPC1200/Source/LPC122x_Vectors.s

DeviceFamily=LPC1200

DeviceSubFamily=LPC122x
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