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PAC52XX Support Package
This guide describes the following features of the PAC52XX CPU support package:

How to create PAC52XX projects

How to open PAC52XX sample projects

PAC52XX specific project properties

PAC52XX specific project templates

Supported PAC52XX devices
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Creating PAC52XX Projects

Creating an PAC52XX C/C++ executable project

To create a new minimal C/C++ executable project:

Select the File > New > New Project menu item.

Select the A C/C++ executable for Active-Semi PAC52XX project template.

Set the required project name and location directory.

Click Next.

If required, change any of the default project settings.

Click Finish to create the project.

Creating an PAC52XX library project

To create a new library project:

Select the File > New > New Project menu item.

Select the A library for Active-Semi PAC52XX project template.

Set the required project name and location directory.

Click Next.

If required, change any of the default project settings.

Click Finish to create the project.

Creating an PAC52XX externally built executable project

To create a new project that will allow you to debug an existing externally built executable file:

Select the File > New > New Project menu item.

Select the An externally built executable for Active-Semi PAC52XX project template.

Set the required project name and location directory.

Click Next.

Set the Load File project property to point to the executable file you want to download and debug.

If required, change any of the other default project settings.

Click Finish to create the project.

Creating an PAC52XX CrossWorks Tasking Library executable project

To create a new C/C++ executable project configured to use the CrossWorks Tasking Library:

Select the File > New > New Project menu item.

Select the A CrossWorks Tasking Library executable for Active-Semi PAC52XX project template.

Set the required project name and location directory.

Click Next.
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If required, change any of the other default project settings.

Click Finish to create the project.

Creating an PAC52XX assembly code only executable project

Please note, this template does not add any C/C++ startup code or libraries and is therefore not suitable for creating

projects that include C/C++ code.

To create a new assembly code only executable project without:

Select the File > New > New Project menu item.

Select the An assembly code only executable for Active-Semi PAC52XX project template.

Set the required project name and location directory.

Click Next.

If required, change any of the other default project settings.

Click Finish to create the project.
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Opening PAC52XX Sample Solutions

PAC52XX Samples Solution

This solution contains general sample projects that run on PAC52XX devices. To open the PAC52XX Samples

Solution:

Select the Tools > Show Installed Packages menu item.

Select the Active-Semi PAC52XX CPU Support Package link.

Select the Samples Solutions > PAC52XX Samples Solution link.

PAC52XX CMSIS-DSP Samples Solution

This solution contains sample projects that use the CMSIS-DSP library running on PAC52XX devices. To open the

PAC52XX CMSIS-DSP Samples Solution:

Select the Tools > Show Installed Packages menu item.

Select the Active-Semi PAC52XX CPU Support Package link.

Select the Sample Solutions > PAC52XX CMSIS-DSP Samples Solution link.
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PAC52XX Project Properties
Projects creating using the project templates in this support package have the following device specific project

properties:

Heap Size

The heap size is set to be 256 bytes when a project is created. The heap size can be modified using the Heap Size

project property.

Section Placement

You can select the memory configuration you require using the Section Placement project property.

For PAC52XX projects, the set of placements are:

Flash - The application runs in internal Flash memory (default).

Flash Vectors In RAM - The application runs in internal Flash memory and exception vectors are copied to

RAM memory.

Flash Copy To RAM - The application starts in internal flash and copies itself to run from internal RAM

memory.

RAM - The application runs from internal RAM memory only.

Stack Sizes

The main stack size is set to be 256 bytes when a project is created.

The process stack size is set to be 0 bytes when a project is created.

The main and process stack sizes can be modified using the Main Stack Size and Process Stack Size project

properties.

To change the location of the stacks, edit the section placement file and place the .stack and .stack_process

sections as required.

Startup From Reset

By default, the application will only startup from power-on/reset in Release configuration. This acts as a safety

net in case you accidently download a program in FLASH during development that crashes and prevents the

debugger from taking control of the target over the debug interface thus rendering the device unusable.

For PAC52XX projects, the Startup From Reset project property can be set to one of the following:

No - The application will not startup from reset.
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Release Only - The application will only startup from reset when built in Release configuration (default).

Yes - The application will always startup from reset.

Target Processor

Once a project has been created you can target different devices by modifying the Target Processor project

property. See the PAC52XX Devices section for details on the files, preprocessor definitions and macro

definitions used when a device is selected.



PAC52XX CPU Support Package Guide PAC52XX Support Package

11

PAC52XX Project Templates
The project template system simplifies the creation of new projects with the IDE, it also system makes it easy to

create new projects with a text editor or script. All that needs to be specified is the project name, the support

packages that the project is dependent on, the target processor and the source files you want to add to the

project. For example, create a file called example.hzp with the following contents:

<!DOCTYPE CrossStudio_Project_File>
<solution Name="Example Solution">
  <project Name="Example Project" template_name="PAC52XX_EXE">
    <configuration Name="Common" package_dependencies="PAC52XX" Target="PAC5223" />
    <folder Name="Source Files">
      <file file_name="file1.c" />
      <file file_name="file2.c" />
    </folder>
  </project>
</solution>

You can also add any other property settings that the project requires such as preprocessor definitions or

include paths using the property save name, for example:

<!DOCTYPE CrossStudio_Project_File>
<solution Name="Example Solution">
  <project Name="Example Project" template_name="PAC52XX_EXE">
    <configuration Name="Common" package_dependencies="PAC52XX" Target="PAC5223"
 c_preprocessor_definitions="MYDEF1=1;MYDEF2=TWO" c_user_include_directories="$(ProjectDir)/
include1;$(ProjectDir)/include2" />
    <folder Name="Source Files">
      <file file_name="file1.c" />
      <file file_name="file2.c" />
    </folder>
  </project>
</solution>

Available PAC52XX project templates

Template Name Template Description

PAC52XX_ASM_EXE PAC52XX Assembly Code Only Executable

PAC52XX_CTL_EXE PAC52XX CTL Executable

PAC52XX_EXE PAC52XX C/C++ Executable

PAC52XX_EXT_EXE PAC52XX Externally Built Executable

PAC52XX_LIB PAC52XX Library
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PAC52XX Devices
This package supports the following PAC52XX devices:

PAC52XX Family
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PAC52XX Family
PAC5210

PAC5220

PAC5223

PAC5250
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PAC5210
Device Details

CMSIS Header File
$(TargetsDir)/PAC52XX/CMSIS/Device/Include/
PAC52XX_device.h

CMSIS Include Path $(TargetsDir)/PAC52XX/CMSIS/Device/Include

CMSIS System File
$(TargetsDir)/PAC52XX/CMSIS/Device/Source/
system_pac52XX.c

Family PAC52XX

Sub Family PAC52XX

Loader File $(TargetsDir)/PAC52XX/Loader/PAC52XX_Loader.elf

Memory Map File
$(TargetsDir)/PAC52XX/XML/
PAC5210_MemoryMap.xml

Register Definition File $(TargetsDir)/PAC52XX/XML/PAC52XX_Registers.xml

Vectors File $(TargetsDir)/PAC52XX/Source/PAC52XX_Vectors.s

Preprocessor Definitions

ARM_MATH_CM0

__PAC5210__

__PAC52XX_FAMILY

__PAC52XX_SUBFAMILY

Memory Segments

FLASH 0x00000000 - 0x00007FFF

RAM 0x20000000 - 0x20001FFF

Project Macros

DeviceIncludePath=$(TargetsDir)/PAC52XX/CMSIS/Device/Include

DeviceHeaderFile=$(TargetsDir)/PAC52XX/CMSIS/Device/Include/PAC52XX_device.h

DeviceLoaderFile=$(TargetsDir)/PAC52XX/Loader/PAC52XX_Loader.elf

DeviceRegisterDefinitionFile=$(TargetsDir)/PAC52XX/XML/PAC52XX_Registers.xml

DeviceSystemFile=$(TargetsDir)/PAC52XX/CMSIS/Device/Source/system_pac52XX.c

DeviceVectorsFile=$(TargetsDir)/PAC52XX/Source/PAC52XX_Vectors.s

DeviceFamily=PAC52XX

DeviceSubFamily=PAC52XX
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PAC5220
Device Details

CMSIS Header File
$(TargetsDir)/PAC52XX/CMSIS/Device/Include/
PAC52XX_device.h

CMSIS Include Path $(TargetsDir)/PAC52XX/CMSIS/Device/Include

CMSIS System File
$(TargetsDir)/PAC52XX/CMSIS/Device/Source/
system_pac52XX.c

Family PAC52XX

Sub Family PAC52XX

Loader File $(TargetsDir)/PAC52XX/Loader/PAC52XX_Loader.elf

Memory Map File
$(TargetsDir)/PAC52XX/XML/
PAC5220_MemoryMap.xml

Register Definition File $(TargetsDir)/PAC52XX/XML/PAC52XX_Registers.xml

Vectors File $(TargetsDir)/PAC52XX/Source/PAC52XX_Vectors.s

Preprocessor Definitions

ARM_MATH_CM0

__PAC5220__

__PAC52XX_FAMILY

__PAC52XX_SUBFAMILY

Memory Segments

FLASH 0x00000000 - 0x00007FFF

RAM 0x20000000 - 0x20001FFF

Project Macros

DeviceIncludePath=$(TargetsDir)/PAC52XX/CMSIS/Device/Include

DeviceHeaderFile=$(TargetsDir)/PAC52XX/CMSIS/Device/Include/PAC52XX_device.h

DeviceLoaderFile=$(TargetsDir)/PAC52XX/Loader/PAC52XX_Loader.elf

DeviceRegisterDefinitionFile=$(TargetsDir)/PAC52XX/XML/PAC52XX_Registers.xml

DeviceSystemFile=$(TargetsDir)/PAC52XX/CMSIS/Device/Source/system_pac52XX.c

DeviceVectorsFile=$(TargetsDir)/PAC52XX/Source/PAC52XX_Vectors.s

DeviceFamily=PAC52XX

DeviceSubFamily=PAC52XX



PAC52XX CPU Support Package Guide PAC52XX Support Package

16

PAC5223
Device Details

CMSIS Header File
$(TargetsDir)/PAC52XX/CMSIS/Device/Include/
PAC52XX_device.h

CMSIS Include Path $(TargetsDir)/PAC52XX/CMSIS/Device/Include

CMSIS System File
$(TargetsDir)/PAC52XX/CMSIS/Device/Source/
system_pac52XX.c

Family PAC52XX

Sub Family PAC52XX

Loader File $(TargetsDir)/PAC52XX/Loader/PAC52XX_Loader.elf

Memory Map File
$(TargetsDir)/PAC52XX/XML/
PAC5223_MemoryMap.xml

Register Definition File $(TargetsDir)/PAC52XX/XML/PAC52XX_Registers.xml

Vectors File $(TargetsDir)/PAC52XX/Source/PAC52XX_Vectors.s

Preprocessor Definitions

ARM_MATH_CM0

__PAC5223__

__PAC52XX_FAMILY

__PAC52XX_SUBFAMILY

Memory Segments

FLASH 0x00000000 - 0x00007FFF

RAM 0x20000000 - 0x20001FFF

Project Macros

DeviceIncludePath=$(TargetsDir)/PAC52XX/CMSIS/Device/Include

DeviceHeaderFile=$(TargetsDir)/PAC52XX/CMSIS/Device/Include/PAC52XX_device.h

DeviceLoaderFile=$(TargetsDir)/PAC52XX/Loader/PAC52XX_Loader.elf

DeviceRegisterDefinitionFile=$(TargetsDir)/PAC52XX/XML/PAC52XX_Registers.xml

DeviceSystemFile=$(TargetsDir)/PAC52XX/CMSIS/Device/Source/system_pac52XX.c

DeviceVectorsFile=$(TargetsDir)/PAC52XX/Source/PAC52XX_Vectors.s

DeviceFamily=PAC52XX

DeviceSubFamily=PAC52XX
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PAC5250
Device Details

CMSIS Header File
$(TargetsDir)/PAC52XX/CMSIS/Device/Include/
PAC52XX_device.h

CMSIS Include Path $(TargetsDir)/PAC52XX/CMSIS/Device/Include

CMSIS System File
$(TargetsDir)/PAC52XX/CMSIS/Device/Source/
system_pac52XX.c

Family PAC52XX

Sub Family PAC52XX

Loader File $(TargetsDir)/PAC52XX/Loader/PAC52XX_Loader.elf

Memory Map File
$(TargetsDir)/PAC52XX/XML/
PAC5250_MemoryMap.xml

Register Definition File $(TargetsDir)/PAC52XX/XML/PAC52XX_Registers.xml

Vectors File $(TargetsDir)/PAC52XX/Source/PAC52XX_Vectors.s

Preprocessor Definitions

ARM_MATH_CM0

__PAC5250__

__PAC52XX_FAMILY

__PAC52XX_SUBFAMILY

Memory Segments

FLASH 0x00000000 - 0x00007FFF

RAM 0x20000000 - 0x20001FFF

Project Macros

DeviceIncludePath=$(TargetsDir)/PAC52XX/CMSIS/Device/Include

DeviceHeaderFile=$(TargetsDir)/PAC52XX/CMSIS/Device/Include/PAC52XX_device.h

DeviceLoaderFile=$(TargetsDir)/PAC52XX/Loader/PAC52XX_Loader.elf

DeviceRegisterDefinitionFile=$(TargetsDir)/PAC52XX/XML/PAC52XX_Registers.xml

DeviceSystemFile=$(TargetsDir)/PAC52XX/CMSIS/Device/Source/system_pac52XX.c

DeviceVectorsFile=$(TargetsDir)/PAC52XX/Source/PAC52XX_Vectors.s

DeviceFamily=PAC52XX

DeviceSubFamily=PAC52XX
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