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SAM4C Support Package
This guide describes the following features of the SAM4C CPU support package:

How to create SAM4C projects

How to open SAM4C sample projects

SAM4C specific project properties

SAM4C specific project templates

Supported SAM4C devices
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Creating SAM4C Projects

Creating an SAM4C C/C++ executable project

To create a new minimal C/C++ executable project:

Select the File > New > New Project menu item.

Select the A C/C++ executable for Microchip SAM4C project template.

Set the required project name and location directory.

Click Next.

If required, change any of the default project settings.

Click Finish to create the project.

Creating an SAM4C library project

To create a new library project:

Select the File > New > New Project menu item.

Select the A library for Microchip SAM4C project template.

Set the required project name and location directory.

Click Next.

If required, change any of the default project settings.

Click Finish to create the project.

Creating an SAM4C externally built executable project

To create a new project that will allow you to debug an existing externally built executable file:

Select the File > New > New Project menu item.

Select the An externally built executable for Microchip SAM4C project template.

Set the required project name and location directory.

Click Next.

Set the Load File project property to point to the executable file you want to download and debug.

If required, change any of the other default project settings.

Click Finish to create the project.

Creating an SAM4C CrossWorks Tasking Library executable project

To create a new C/C++ executable project configured to use the CrossWorks Tasking Library:

Select the File > New > New Project menu item.

Select the A CrossWorks Tasking Library executable for Microchip SAM4C project template.

Set the required project name and location directory.

Click Next.
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If required, change any of the other default project settings.

Click Finish to create the project.

Creating an SAM4C assembly code only executable project

Please note, this template does not add any C/C++ startup code or libraries and is therefore not suitable for creating

projects that include C/C++ code.

To create a new assembly code only executable project without:

Select the File > New > New Project menu item.

Select the An assembly code only executable for Microchip SAM4C project template.

Set the required project name and location directory.

Click Next.

If required, change any of the other default project settings.

Click Finish to create the project.
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Opening SAM4C Sample Solutions

SAM4C Samples Solution

This solution contains general sample projects that run on SAM4C devices. To open the SAM4C Samples

Solution:

Select the Tools > Show Installed Packages menu item.

Select the Microchip SAM4C CPU Support Package link.

Select the Samples Solutions > SAM4C Samples Solution link.

SAM4C CMSIS-DSP Samples Solution

This solution contains sample projects that use the CMSIS-DSP library running on SAM4C devices. To open the

SAM4C CMSIS-DSP Samples Solution:

Select the Tools > Show Installed Packages menu item.

Select the Microchip SAM4C CPU Support Package link.

Select the Sample Solutions > SAM4C CMSIS-DSP Samples Solution link.
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SAM4C Project Properties
Projects creating using the project templates in this support package have the following device specific project

properties:

Heap Size

The heap size is set to be 256 bytes when a project is created. The heap size can be modified using the Heap Size

project property.

Section Placement

You can select the memory configuration you require using the Section Placement project property.

For SAM4C projects, the set of placements are:

Flash - The application runs in internal Flash memory (default).

Flash Vectors In RAM - The application runs in internal Flash memory and exception vectors are copied to

RAM memory.

Flash Copy To RAM - The application starts in internal flash and copies itself to run from internal RAM

memory.

RAM - The application runs from internal RAM memory only.

Stack Sizes

The main stack size is set to be 256 bytes when a project is created.

The process stack size is set to be 0 bytes when a project is created.

The main and process stack sizes can be modified using the Main Stack Size and Process Stack Size project

properties.

To change the location of the stacks, edit the section placement file and place the .stack and .stack_process

sections as required.

Startup From Reset

By default, the application will only startup from power-on/reset in Release configuration. This acts as a safety

net in case you accidently download a program in FLASH during development that crashes and prevents the

debugger from taking control of the target over the debug interface thus rendering the device unusable.

For SAM4C projects, the Startup From Reset project property can be set to one of the following:

No - The application will not startup from reset.
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Release Only - The application will only startup from reset when built in Release configuration (default).

Yes - The application will always startup from reset.

Target Processor

Once a project has been created you can target different devices by modifying the Target Processor project

property. See the SAM4C Devices section for details on the files, preprocessor definitions and macro definitions

used when a device is selected.
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SAM4C Project Templates
The project template system simplifies the creation of new projects with the IDE, it also system makes it easy to

create new projects with a text editor or script. All that needs to be specified is the project name, the support

packages that the project is dependent on, the target processor and the source files you want to add to the

project. For example, create a file called example.hzp with the following contents:

<!DOCTYPE CrossStudio_Project_File>
<solution Name="Example Solution">
  <project Name="Example Project" template_name="SAM4C_EXE">
    <configuration Name="Common" package_dependencies="SAM4C" Target="ATSAM4C16C_0" />
    <folder Name="Source Files">
      <file file_name="file1.c" />
      <file file_name="file2.c" />
    </folder>
  </project>
</solution>

You can also add any other property settings that the project requires such as preprocessor definitions or

include paths using the property save name, for example:

<!DOCTYPE CrossStudio_Project_File>
<solution Name="Example Solution">
  <project Name="Example Project" template_name="SAM4C_EXE">
    <configuration Name="Common" package_dependencies="SAM4C" Target="ATSAM4C16C_0"
 c_preprocessor_definitions="MYDEF1=1;MYDEF2=TWO" c_user_include_directories="$(ProjectDir)/
include1;$(ProjectDir)/include2" />
    <folder Name="Source Files">
      <file file_name="file1.c" />
      <file file_name="file2.c" />
    </folder>
  </project>
</solution>

Available SAM4C project templates

Template Name Template Description

SAM4C_ASM_EXE SAM4C Assembly Code Only Executable

SAM4C_CTL_EXE SAM4C CTL Executable

SAM4C_EXE SAM4C C/C++ Executable

SAM4C_EXT_EXE SAM4C Externally Built Executable

SAM4C_LIB SAM4C Library
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SAM4C Devices
This package supports the following SAM4C devices:

SAM4C Family

SAM4C32 Family
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SAM4C Family
ATSAM4C4C_0

ATSAM4C4C_1

ATSAM4C8C_0

ATSAM4C8C_1

ATSAM4C16C_0

ATSAM4C16C_1
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ATSAM4C4C_0
Device Details

CMSIS Header File
$(TargetsDir)/SAM4C/CMSIS/Device/Include/SAM4C/
sam4c.h

CMSIS Include Path $(TargetsDir)/SAM4C/CMSIS/Device/Include/SAM4C

CMSIS System File
$(TargetsDir)/SAM4C/CMSIS/Device/Source/
system_SAM4C.c

Family SAM4C

Sub Family SAM4C

Loader File
$(TargetsDir)/SAM4C/Loader/
ATSAM4C_256_Loader.elf

Memory Map File
$(TargetsDir)/SAM4C/XML/
ATSAM4C4C_0_MemoryMap.xml

Register Definition File
$(TargetsDir)/SAM4C/XML/
ATSAM4C4C_0_Registers.xml

Vectors File $(TargetsDir)/SAM4C/Source/ATSAM4C4C_0_Vectors.s

Preprocessor Definitions

ARM_MATH_CM4

__SAM4C4C_0__

__SAM4C_FAMILY

__SAM4C_SUBFAMILY

Memory Segments

FLASH 0x01000000 - 0x0103FFFF

RAM 0x20000000 - 0x2001FFFF

Project Macros

DeviceIncludePath=$(TargetsDir)/SAM4C/CMSIS/Device/Include/SAM4C

DeviceHeaderFile=$(TargetsDir)/SAM4C/CMSIS/Device/Include/SAM4C/sam4c.h

DeviceLoaderFile=$(TargetsDir)/SAM4C/Loader/ATSAM4C_256_Loader.elf

DeviceRegisterDefinitionFile=$(TargetsDir)/SAM4C/XML/ATSAM4C4C_0_Registers.xml

DeviceSystemFile=$(TargetsDir)/SAM4C/CMSIS/Device/Source/system_SAM4C.c

DeviceVectorsFile=$(TargetsDir)/SAM4C/Source/ATSAM4C4C_0_Vectors.s

DeviceFamily=SAM4C

DeviceSubFamily=SAM4C
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ATSAM4C4C_1
Device Details

CMSIS Header File
$(TargetsDir)/SAM4C/CMSIS/Device/Include/SAM4C/
sam4c.h

CMSIS Include Path $(TargetsDir)/SAM4C/CMSIS/Device/Include/SAM4C

CMSIS System File
$(TargetsDir)/SAM4C/CMSIS/Device/Source/
system_SAM4C.c

Family SAM4C

Sub Family SAM4C

Loader File $(TargetsDir)/SAM4C/Loader/

Memory Map File
$(TargetsDir)/SAM4C/XML/
ATSAM4C4C_1_MemoryMap.xml

Register Definition File
$(TargetsDir)/SAM4C/XML/
ATSAM4C4C_1_Registers.xml

Vectors File $(TargetsDir)/SAM4C/Source/ATSAM4C4C_1_Vectors.s

Preprocessor Definitions

ARM_MATH_CM4

__SAM4C4C_1__

__SAM4C_FAMILY

__SAM4C_SUBFAMILY

Memory Segments

FLASH 0x00000000 - 0x00003FFF

RAM 0x20100000 - 0x20101FFF

Project Macros

DeviceIncludePath=$(TargetsDir)/SAM4C/CMSIS/Device/Include/SAM4C

DeviceHeaderFile=$(TargetsDir)/SAM4C/CMSIS/Device/Include/SAM4C/sam4c.h

DeviceLoaderFile=

DeviceRegisterDefinitionFile=$(TargetsDir)/SAM4C/XML/ATSAM4C4C_1_Registers.xml

DeviceSystemFile=$(TargetsDir)/SAM4C/CMSIS/Device/Source/system_SAM4C.c

DeviceVectorsFile=$(TargetsDir)/SAM4C/Source/ATSAM4C4C_1_Vectors.s

DeviceFamily=SAM4C

DeviceSubFamily=SAM4C
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ATSAM4C8C_0
Device Details

CMSIS Header File
$(TargetsDir)/SAM4C/CMSIS/Device/Include/SAM4C/
sam4c.h

CMSIS Include Path $(TargetsDir)/SAM4C/CMSIS/Device/Include/SAM4C

CMSIS System File
$(TargetsDir)/SAM4C/CMSIS/Device/Source/
system_SAM4C.c

Family SAM4C

Sub Family SAM4C

Loader File
$(TargetsDir)/SAM4C/Loader/
ATSAM4C_512_Loader.elf

Memory Map File
$(TargetsDir)/SAM4C/XML/
ATSAM4C8C_0_MemoryMap.xml

Register Definition File
$(TargetsDir)/SAM4C/XML/
ATSAM4C8C_0_Registers.xml

Vectors File $(TargetsDir)/SAM4C/Source/ATSAM4C8C_0_Vectors.s

Preprocessor Definitions

ARM_MATH_CM4

__SAM4C8C_0__

__SAM4C_FAMILY

__SAM4C_SUBFAMILY

Memory Segments

FLASH 0x01000000 - 0x0107FFFF

RAM 0x20000000 - 0x2001FFFF

Project Macros

DeviceIncludePath=$(TargetsDir)/SAM4C/CMSIS/Device/Include/SAM4C

DeviceHeaderFile=$(TargetsDir)/SAM4C/CMSIS/Device/Include/SAM4C/sam4c.h

DeviceLoaderFile=$(TargetsDir)/SAM4C/Loader/ATSAM4C_512_Loader.elf

DeviceRegisterDefinitionFile=$(TargetsDir)/SAM4C/XML/ATSAM4C8C_0_Registers.xml

DeviceSystemFile=$(TargetsDir)/SAM4C/CMSIS/Device/Source/system_SAM4C.c

DeviceVectorsFile=$(TargetsDir)/SAM4C/Source/ATSAM4C8C_0_Vectors.s

DeviceFamily=SAM4C

DeviceSubFamily=SAM4C
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ATSAM4C8C_1
Device Details

CMSIS Header File
$(TargetsDir)/SAM4C/CMSIS/Device/Include/SAM4C/
sam4c.h

CMSIS Include Path $(TargetsDir)/SAM4C/CMSIS/Device/Include/SAM4C

CMSIS System File
$(TargetsDir)/SAM4C/CMSIS/Device/Source/
system_SAM4C.c

Family SAM4C

Sub Family SAM4C

Loader File $(TargetsDir)/SAM4C/Loader/

Memory Map File
$(TargetsDir)/SAM4C/XML/
ATSAM4C8C_1_MemoryMap.xml

Register Definition File
$(TargetsDir)/SAM4C/XML/
ATSAM4C8C_1_Registers.xml

Vectors File $(TargetsDir)/SAM4C/Source/ATSAM4C8C_1_Vectors.s

Preprocessor Definitions

ARM_MATH_CM4

__SAM4C8C_1__

__SAM4C_FAMILY

__SAM4C_SUBFAMILY

Memory Segments

FLASH 0x00000000 - 0x00003FFF

RAM 0x20100000 - 0x20101FFF

Project Macros

DeviceIncludePath=$(TargetsDir)/SAM4C/CMSIS/Device/Include/SAM4C

DeviceHeaderFile=$(TargetsDir)/SAM4C/CMSIS/Device/Include/SAM4C/sam4c.h

DeviceLoaderFile=

DeviceRegisterDefinitionFile=$(TargetsDir)/SAM4C/XML/ATSAM4C8C_1_Registers.xml

DeviceSystemFile=$(TargetsDir)/SAM4C/CMSIS/Device/Source/system_SAM4C.c

DeviceVectorsFile=$(TargetsDir)/SAM4C/Source/ATSAM4C8C_1_Vectors.s

DeviceFamily=SAM4C

DeviceSubFamily=SAM4C
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ATSAM4C16C_0
Device Details

CMSIS Header File
$(TargetsDir)/SAM4C/CMSIS/Device/Include/SAM4C/
sam4c.h

CMSIS Include Path $(TargetsDir)/SAM4C/CMSIS/Device/Include/SAM4C

CMSIS System File
$(TargetsDir)/SAM4C/CMSIS/Device/Source/
system_SAM4C.c

Family SAM4C

Sub Family SAM4C

Loader File
$(TargetsDir)/SAM4C/Loader/
ATSAM4C_1024_Loader.elf

Memory Map File
$(TargetsDir)/SAM4C/XML/
ATSAM4C16C_0_MemoryMap.xml

Register Definition File
$(TargetsDir)/SAM4C/XML/
ATSAM4C16C_0_Registers.xml

Vectors File
$(TargetsDir)/SAM4C/Source/
ATSAM4C16C_0_Vectors.s

Preprocessor Definitions

ARM_MATH_CM4

__SAM4C16C_0__

__SAM4C_FAMILY

__SAM4C_SUBFAMILY

Memory Segments

FLASH 0x01000000 - 0x010FFFFF

RAM 0x20000000 - 0x2001FFFF

Project Macros

DeviceIncludePath=$(TargetsDir)/SAM4C/CMSIS/Device/Include/SAM4C

DeviceHeaderFile=$(TargetsDir)/SAM4C/CMSIS/Device/Include/SAM4C/sam4c.h

DeviceLoaderFile=$(TargetsDir)/SAM4C/Loader/ATSAM4C_1024_Loader.elf

DeviceRegisterDefinitionFile=$(TargetsDir)/SAM4C/XML/ATSAM4C16C_0_Registers.xml

DeviceSystemFile=$(TargetsDir)/SAM4C/CMSIS/Device/Source/system_SAM4C.c

DeviceVectorsFile=$(TargetsDir)/SAM4C/Source/ATSAM4C16C_0_Vectors.s

DeviceFamily=SAM4C

DeviceSubFamily=SAM4C
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ATSAM4C16C_1
Device Details

CMSIS Header File
$(TargetsDir)/SAM4C/CMSIS/Device/Include/SAM4C/
sam4c.h

CMSIS Include Path $(TargetsDir)/SAM4C/CMSIS/Device/Include/SAM4C

CMSIS System File
$(TargetsDir)/SAM4C/CMSIS/Device/Source/
system_SAM4C.c

Family SAM4C

Sub Family SAM4C

Loader File $(TargetsDir)/SAM4C/Loader/

Memory Map File
$(TargetsDir)/SAM4C/XML/
ATSAM4C16C_1_MemoryMap.xml

Register Definition File
$(TargetsDir)/SAM4C/XML/
ATSAM4C16C_1_Registers.xml

Vectors File
$(TargetsDir)/SAM4C/Source/
ATSAM4C16C_1_Vectors.s

Preprocessor Definitions

ARM_MATH_CM4

__SAM4C16C_1__

__SAM4C_FAMILY

__SAM4C_SUBFAMILY

Memory Segments

FLASH 0x00000000 - 0x00003FFF

RAM 0x20100000 - 0x20101FFF

Project Macros

DeviceIncludePath=$(TargetsDir)/SAM4C/CMSIS/Device/Include/SAM4C

DeviceHeaderFile=$(TargetsDir)/SAM4C/CMSIS/Device/Include/SAM4C/sam4c.h

DeviceLoaderFile=

DeviceRegisterDefinitionFile=$(TargetsDir)/SAM4C/XML/ATSAM4C16C_1_Registers.xml

DeviceSystemFile=$(TargetsDir)/SAM4C/CMSIS/Device/Source/system_SAM4C.c

DeviceVectorsFile=$(TargetsDir)/SAM4C/Source/ATSAM4C16C_1_Vectors.s

DeviceFamily=SAM4C

DeviceSubFamily=SAM4C
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SAM4C32 Family
ATSAM4C32C_0

ATSAM4C32C_1

ATSAM4C32E_0

ATSAM4C32E_1
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ATSAM4C32C_0
Device Details

CMSIS Header File
$(TargetsDir)/SAM4C/CMSIS/Device/Include/
SAM4C32/sam4c32.h

CMSIS Include Path $(TargetsDir)/SAM4C/CMSIS/Device/Include/SAM4C32

CMSIS System File
$(TargetsDir)/SAM4C/CMSIS/Device/Source/
system_sam4c32.c

Family SAM4C

Sub Family SAM4C32

Loader File
$(TargetsDir)/SAM4C/Loader/
ATSAM4C32_2048_Loader.elf

Memory Map File
$(TargetsDir)/SAM4C/XML/
ATSAM4C32C_0_MemoryMap.xml

Register Definition File
$(TargetsDir)/SAM4C/XML/
ATSAM4C32C_0_Registers.xml

Vectors File
$(TargetsDir)/SAM4C/Source/
ATSAM4C32C_0_Vectors.s

Preprocessor Definitions

ARM_MATH_CM4

__SAM4C32C_0__

__SAM4C32_SUBFAMILY

__SAM4C_FAMILY

Memory Segments

FLASH 0x01000000 - 0x010FFFFF

RAM 0x20000000 - 0x2003FFFF

Project Macros

DeviceIncludePath=$(TargetsDir)/SAM4C/CMSIS/Device/Include/SAM4C32

DeviceHeaderFile=$(TargetsDir)/SAM4C/CMSIS/Device/Include/SAM4C32/sam4c32.h

DeviceLoaderFile=$(TargetsDir)/SAM4C/Loader/ATSAM4C32_2048_Loader.elf

DeviceRegisterDefinitionFile=$(TargetsDir)/SAM4C/XML/ATSAM4C32C_0_Registers.xml

DeviceSystemFile=$(TargetsDir)/SAM4C/CMSIS/Device/Source/system_sam4c32.c

DeviceVectorsFile=$(TargetsDir)/SAM4C/Source/ATSAM4C32C_0_Vectors.s

DeviceFamily=SAM4C

DeviceSubFamily=SAM4C32
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ATSAM4C32C_1
Device Details

CMSIS Header File
$(TargetsDir)/SAM4C/CMSIS/Device/Include/
SAM4C32/sam4c32.h

CMSIS Include Path $(TargetsDir)/SAM4C/CMSIS/Device/Include/SAM4C32

CMSIS System File
$(TargetsDir)/SAM4C/CMSIS/Device/Source/
system_sam4c32.c

Family SAM4C

Sub Family SAM4C32

Loader File $(TargetsDir)/SAM4C/Loader/

Memory Map File
$(TargetsDir)/SAM4C/XML/
ATSAM4C32C_1_MemoryMap.xml

Register Definition File
$(TargetsDir)/SAM4C/XML/
ATSAM4C32C_1_Registers.xml

Vectors File
$(TargetsDir)/SAM4C/Source/
ATSAM4C32C_1_Vectors.s

Preprocessor Definitions

ARM_MATH_CM4

__SAM4C32C_1__

__SAM4C32_SUBFAMILY

__SAM4C_FAMILY

Memory Segments

FLASH 0x00000000 - 0x00007FFF

RAM 0x20100000 - 0x20103FFF

Project Macros

DeviceIncludePath=$(TargetsDir)/SAM4C/CMSIS/Device/Include/SAM4C32

DeviceHeaderFile=$(TargetsDir)/SAM4C/CMSIS/Device/Include/SAM4C32/sam4c32.h

DeviceLoaderFile=

DeviceRegisterDefinitionFile=$(TargetsDir)/SAM4C/XML/ATSAM4C32C_1_Registers.xml

DeviceSystemFile=$(TargetsDir)/SAM4C/CMSIS/Device/Source/system_sam4c32.c

DeviceVectorsFile=$(TargetsDir)/SAM4C/Source/ATSAM4C32C_1_Vectors.s

DeviceFamily=SAM4C

DeviceSubFamily=SAM4C32
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ATSAM4C32E_0
Device Details

CMSIS Header File
$(TargetsDir)/SAM4C/CMSIS/Device/Include/
SAM4C32/sam4c32.h

CMSIS Include Path $(TargetsDir)/SAM4C/CMSIS/Device/Include/SAM4C32

CMSIS System File
$(TargetsDir)/SAM4C/CMSIS/Device/Source/
system_sam4c32.c

Family SAM4C

Sub Family SAM4C32

Loader File
$(TargetsDir)/SAM4C/Loader/
ATSAM4C32_2048_Loader.elf

Memory Map File
$(TargetsDir)/SAM4C/XML/
ATSAM4C32E_0_MemoryMap.xml

Register Definition File
$(TargetsDir)/SAM4C/XML/
ATSAM4C32E_0_Registers.xml

Vectors File
$(TargetsDir)/SAM4C/Source/
ATSAM4C32E_0_Vectors.s

Preprocessor Definitions

ARM_MATH_CM4

__SAM4C32E_0__

__SAM4C32_SUBFAMILY

__SAM4C_FAMILY

Memory Segments

FLASH 0x01000000 - 0x010FFFFF

RAM 0x20000000 - 0x2003FFFF

Project Macros

DeviceIncludePath=$(TargetsDir)/SAM4C/CMSIS/Device/Include/SAM4C32

DeviceHeaderFile=$(TargetsDir)/SAM4C/CMSIS/Device/Include/SAM4C32/sam4c32.h

DeviceLoaderFile=$(TargetsDir)/SAM4C/Loader/ATSAM4C32_2048_Loader.elf

DeviceRegisterDefinitionFile=$(TargetsDir)/SAM4C/XML/ATSAM4C32E_0_Registers.xml

DeviceSystemFile=$(TargetsDir)/SAM4C/CMSIS/Device/Source/system_sam4c32.c

DeviceVectorsFile=$(TargetsDir)/SAM4C/Source/ATSAM4C32E_0_Vectors.s

DeviceFamily=SAM4C

DeviceSubFamily=SAM4C32
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ATSAM4C32E_1
Device Details

CMSIS Header File
$(TargetsDir)/SAM4C/CMSIS/Device/Include/
SAM4C32/sam4c32.h

CMSIS Include Path $(TargetsDir)/SAM4C/CMSIS/Device/Include/SAM4C32

CMSIS System File
$(TargetsDir)/SAM4C/CMSIS/Device/Source/
system_sam4c32.c

Family SAM4C

Sub Family SAM4C32

Loader File $(TargetsDir)/SAM4C/Loader/

Memory Map File
$(TargetsDir)/SAM4C/XML/
ATSAM4C32E_1_MemoryMap.xml

Register Definition File
$(TargetsDir)/SAM4C/XML/
ATSAM4C32E_1_Registers.xml

Vectors File
$(TargetsDir)/SAM4C/Source/
ATSAM4C32E_1_Vectors.s

Preprocessor Definitions

ARM_MATH_CM4

__SAM4C32E_1__

__SAM4C32_SUBFAMILY

__SAM4C_FAMILY

Memory Segments

FLASH 0x00000000 - 0x00007FFF

RAM 0x20100000 - 0x20103FFF

Project Macros

DeviceIncludePath=$(TargetsDir)/SAM4C/CMSIS/Device/Include/SAM4C32

DeviceHeaderFile=$(TargetsDir)/SAM4C/CMSIS/Device/Include/SAM4C32/sam4c32.h

DeviceLoaderFile=

DeviceRegisterDefinitionFile=$(TargetsDir)/SAM4C/XML/ATSAM4C32E_1_Registers.xml

DeviceSystemFile=$(TargetsDir)/SAM4C/CMSIS/Device/Source/system_sam4c32.c

DeviceVectorsFile=$(TargetsDir)/SAM4C/Source/ATSAM4C32E_1_Vectors.s

DeviceFamily=SAM4C

DeviceSubFamily=SAM4C32
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