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SAM E Support Package
This guide describes the following features of the SAM E CPU support package:

How to create SAM E projects

How to open SAM E sample projects

SAM E specific project properties

SAM E specific project templates

Supported SAM E devices

Troubleshooting
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Creating SAM E Projects

Creating an SAM E C/C++ executable project

To create a new minimal C/C++ executable project:

Select the File > New > New Project menu item.

Select the A C/C++ executable for Microchip SAM E project template.

Set the required project name and location directory.

Click Next.

If required, change any of the default project settings.

Click Finish to create the project.

Creating an SAM E library project

To create a new library project:

Select the File > New > New Project menu item.

Select the A library for Microchip SAM E project template.

Set the required project name and location directory.

Click Next.

If required, change any of the default project settings.

Click Finish to create the project.

Creating an SAM E externally built executable project

To create a new project that will allow you to debug an existing externally built executable file:

Select the File > New > New Project menu item.

Select the An externally built executable for Microchip SAM E project template.

Set the required project name and location directory.

Click Next.

Set the Load File project property to point to the executable file you want to download and debug.

If required, change any of the other default project settings.

Click Finish to create the project.

Creating an SAM E CrossWorks Tasking Library executable project

To create a new C/C++ executable project configured to use the CrossWorks Tasking Library:

Select the File > New > New Project menu item.

Select the A CrossWorks Tasking Library executable for Microchip SAM E project template.

Set the required project name and location directory.

Click Next.
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If required, change any of the other default project settings.

Click Finish to create the project.

Creating an SAM E assembly code only executable project

Please note, this template does not add any C/C++ startup code or libraries and is therefore not suitable for creating

projects that include C/C++ code.

To create a new assembly code only executable project without:

Select the File > New > New Project menu item.

Select the An assembly code only executable for Microchip SAM E project template.

Set the required project name and location directory.

Click Next.

If required, change any of the other default project settings.

Click Finish to create the project.
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Opening SAM E Sample Solutions

SAM E Samples Solution

This solution contains general sample projects that run on SAM E devices. To open the SAM E Samples Solution:

Select the Tools > Show Installed Packages menu item.

Select the Microchip SAM E CPU Support Package link.

Select the Samples Solutions > SAM E Samples Solution link.

SAM E CMSIS-DSP Samples Solution

This solution contains sample projects that use the CMSIS-DSP library running on SAM E devices. To open the

SAM E CMSIS-DSP Samples Solution:

Select the Tools > Show Installed Packages menu item.

Select the Microchip SAM E CPU Support Package link.

Select the Sample Solutions > SAM E CMSIS-DSP Samples Solution link.
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SAM E Project Properties
Projects creating using the project templates in this support package have the following device specific project

properties:

Heap Size

The heap size is set to be 256 bytes when a project is created. The heap size can be modified using the Heap Size

project property.

Section Placement

You can select the memory configuration you require using the Section Placement project property.

For SAM E projects, the set of placements are:

Flash - The application runs in internal Flash memory (default).

Flash Vectors In RAM - The application runs in internal Flash memory and exception vectors are copied to

RAM memory.

Flash Copy To RAM - The application starts in internal flash and copies itself to run internal RAM memory.

RAM - The application runs internal RAM memory.

Stack Sizes

The main stack size is set to be 256 bytes when a project is created.

The process stack size is set to be 0 bytes when a project is created.

The main and process stack sizes can be modified using the Main Stack Size and Process Stack Size project

properties.

To change the location of the stacks, edit the section placement file and place the .stack and .stack_process

sections as required.

Startup From Reset

By default, the application will only startup from power-on/reset in Release configuration. This acts as a safety

net in case you accidently download a program in FLASH during development that crashes and prevents the

debugger from taking control of the target over the debug interface thus rendering the device unusable.

For SAM E projects, the Startup From Reset project property can be set to one of the following:

No - The application will not startup from reset.

Release Only - The application will only startup from reset when built in Release configuration (default).

Yes - The application will always startup from reset.
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Target Processor

Once a project has been created you can target different devices by modifying the Target Processor project

property. See the SAM E Devices section for details on the files, preprocessor definitions and macro definitions

used when a device is selected.

Use On-Chip RC Oscillator

The Build Options > Use On-Chip RC Oscillator project property can be set to one of the following:

No - The startup code will configure the device to use an external oscillator (default).

Yes - The startup code will configure the device to use the on-chip RC oscillator.

TCM Configuration

The Build Options > TCM Configuration project property can be set to one of the following:

ITCM and DTCM Disabled - The startup code will configure the device to have no ITCM and DTCM

(default).

32 Kbytes ITCM and DTCM - The startup code will configure the device to have a 32 Kbyte ITCM and

DTCM.

64 Kbytes ITCM and DTCM - The startup code will configure the device to have a 64 Kbyte ITCM and

DTCM.

128 Kbytes ITCM and DTCM - The startup code will configure the device to have a 128 Kbyte ITCM and

DTCM.
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SAM E Project Templates
The project template system simplifies the creation of new projects with the IDE, it also system makes it easy to

create new projects with a text editor or script. All that needs to be specified is the project name, the support

packages that the project is dependent on, the target processor and the source files you want to add to the

project. For example, create a file called example.hzp with the following contents:

<!DOCTYPE CrossStudio_Project_File>
<solution Name="Example Solution">
  <project Name="Example Project" template_name="SAM_E_EXE">
    <configuration Name="Common" package_dependencies="SAM_E" Target="ATSAME70J21" />
    <folder Name="Source Files">
      <file file_name="file1.c" />
      <file file_name="file2.c" />
    </folder>
  </project>
</solution>

You can also add any other property settings that the project requires such as preprocessor definitions or

include paths using the property save name, for example:

<!DOCTYPE CrossStudio_Project_File>
<solution Name="Example Solution">
  <project Name="Example Project" template_name="SAM_E_EXE">
    <configuration Name="Common" package_dependencies="SAM_E" Target="ATSAME70J21"
 c_preprocessor_definitions="MYDEF1=1;MYDEF2=TWO" c_user_include_directories="$(ProjectDir)/
include1;$(ProjectDir)/include2" />
    <folder Name="Source Files">
      <file file_name="file1.c" />
      <file file_name="file2.c" />
    </folder>
  </project>
</solution>

Available SAM E project templates

Template Name Template Description

SAM E_ASM_EXE SAM E Assembly Code Only Executable

SAM E_CTL_EXE SAM E CTL Executable

SAM E_EXE SAM E C/C++ Executable

SAM E_EXT_EXE SAM E Externally Built Executable

SAM E_LIB SAM E Library



SAM E CPU Support Package Guide SAM E Support Package

12

SAM E Devices
This package supports the following SAM E devices:

ATSAME70J19

ATSAME70J19B

ATSAME70J20

ATSAME70J20B

ATSAME70J21

ATSAME70J21B

ATSAME70N19

ATSAME70N19B

ATSAME70N20

ATSAME70N20B

ATSAME70N21

ATSAME70N21B

ATSAME70Q19

ATSAME70Q19B

ATSAME70Q20

ATSAME70Q20B

ATSAME70Q21

ATSAME70Q21B
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ATSAME70J19
Device Details

CMSIS Header File $(TargetsDir)/SAM_E/CMSIS/same70a/include/sam.h

CMSIS Include Path $(TargetsDir)/SAM_E/CMSIS/same70a/include

CMSIS System File $(TargetsDir)/SAM_E/CMSIS/source/system_SAME70.c

Family SAM E

Loader File $(TargetsDir)/SAM_E/Loader/SAME70_Loader.elf

Memory Map File
$(TargetsDir)/SAM_E/XML/
ATSAME70J19_MemoryMap.xml

Register Definition File
$(TargetsDir)/SAM_E/XML/
ATSAME70J19_Registers.xml

Vectors File $(TargetsDir)/SAM_E/Source/ATSAME70J19_Vectors.s

Preprocessor Definitions

ARM_MATH_CM7

__SAME70J19__

__SAM_E_FAMILY

Memory Segments

FLASH 0x00400000 - 0x0047FFFF

RAM 0x20400000 - 0x2043FFFF

Project Macros

DeviceIncludePath=$(TargetsDir)/SAM_E/CMSIS/same70a/include

DeviceHeaderFile=$(TargetsDir)/SAM_E/CMSIS/same70a/include/sam.h

DeviceLoaderFile=$(TargetsDir)/SAM_E/Loader/SAME70_Loader.elf

DeviceRegisterDefinitionFile=$(TargetsDir)/SAM_E/XML/ATSAME70J19_Registers.xml

DeviceSystemFile=$(TargetsDir)/SAM_E/CMSIS/source/system_SAME70.c

DeviceVectorsFile=$(TargetsDir)/SAM_E/Source/ATSAME70J19_Vectors.s

DeviceFamily=SAM E
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ATSAME70J19B
Device Details

CMSIS Header File $(TargetsDir)/SAM_E/CMSIS/same70b/include/sam.h

CMSIS Include Path $(TargetsDir)/SAM_E/CMSIS/same70b/include

CMSIS System File $(TargetsDir)/SAM_E/CMSIS/source/system_SAME70.c

Family SAM E

Loader File $(TargetsDir)/SAM_E/Loader/SAME70_Loader.elf

Memory Map File
$(TargetsDir)/SAM_E/XML/
ATSAME70J19B_MemoryMap.xml

Register Definition File
$(TargetsDir)/SAM_E/XML/
ATSAME70J19B_Registers.xml

Vectors File $(TargetsDir)/SAM_E/Source/ATSAME70J19B_Vectors.s

Preprocessor Definitions

ARM_MATH_CM7

__SAME70J19B__

__SAM_E_FAMILY

Memory Segments

FLASH 0x00400000 - 0x0047FFFF

RAM 0x20400000 - 0x2043FFFF

Project Macros

DeviceIncludePath=$(TargetsDir)/SAM_E/CMSIS/same70b/include

DeviceHeaderFile=$(TargetsDir)/SAM_E/CMSIS/same70b/include/sam.h

DeviceLoaderFile=$(TargetsDir)/SAM_E/Loader/SAME70_Loader.elf

DeviceRegisterDefinitionFile=$(TargetsDir)/SAM_E/XML/ATSAME70J19B_Registers.xml

DeviceSystemFile=$(TargetsDir)/SAM_E/CMSIS/source/system_SAME70.c

DeviceVectorsFile=$(TargetsDir)/SAM_E/Source/ATSAME70J19B_Vectors.s

DeviceFamily=SAM E
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ATSAME70J20
Device Details

CMSIS Header File $(TargetsDir)/SAM_E/CMSIS/same70a/include/sam.h

CMSIS Include Path $(TargetsDir)/SAM_E/CMSIS/same70a/include

CMSIS System File $(TargetsDir)/SAM_E/CMSIS/source/system_SAME70.c

Family SAM E

Loader File $(TargetsDir)/SAM_E/Loader/SAME70_Loader.elf

Memory Map File
$(TargetsDir)/SAM_E/XML/
ATSAME70J20_MemoryMap.xml

Register Definition File
$(TargetsDir)/SAM_E/XML/
ATSAME70J20_Registers.xml

Vectors File $(TargetsDir)/SAM_E/Source/ATSAME70J20_Vectors.s

Preprocessor Definitions

ARM_MATH_CM7

__SAME70J20__

__SAM_E_FAMILY

Memory Segments

FLASH 0x00400000 - 0x004FFFFF

RAM 0x20400000 - 0x2045FFFF

Project Macros

DeviceIncludePath=$(TargetsDir)/SAM_E/CMSIS/same70a/include

DeviceHeaderFile=$(TargetsDir)/SAM_E/CMSIS/same70a/include/sam.h

DeviceLoaderFile=$(TargetsDir)/SAM_E/Loader/SAME70_Loader.elf

DeviceRegisterDefinitionFile=$(TargetsDir)/SAM_E/XML/ATSAME70J20_Registers.xml

DeviceSystemFile=$(TargetsDir)/SAM_E/CMSIS/source/system_SAME70.c

DeviceVectorsFile=$(TargetsDir)/SAM_E/Source/ATSAME70J20_Vectors.s

DeviceFamily=SAM E
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ATSAME70J20B
Device Details

CMSIS Header File $(TargetsDir)/SAM_E/CMSIS/same70b/include/sam.h

CMSIS Include Path $(TargetsDir)/SAM_E/CMSIS/same70b/include

CMSIS System File $(TargetsDir)/SAM_E/CMSIS/source/system_SAME70.c

Family SAM E

Loader File $(TargetsDir)/SAM_E/Loader/SAME70_Loader.elf

Memory Map File
$(TargetsDir)/SAM_E/XML/
ATSAME70J20B_MemoryMap.xml

Register Definition File
$(TargetsDir)/SAM_E/XML/
ATSAME70J20B_Registers.xml

Vectors File $(TargetsDir)/SAM_E/Source/ATSAME70J20B_Vectors.s

Preprocessor Definitions

ARM_MATH_CM7

__SAME70J20B__

__SAM_E_FAMILY

Memory Segments

FLASH 0x00400000 - 0x004FFFFF

RAM 0x20400000 - 0x2045FFFF

Project Macros

DeviceIncludePath=$(TargetsDir)/SAM_E/CMSIS/same70b/include

DeviceHeaderFile=$(TargetsDir)/SAM_E/CMSIS/same70b/include/sam.h

DeviceLoaderFile=$(TargetsDir)/SAM_E/Loader/SAME70_Loader.elf

DeviceRegisterDefinitionFile=$(TargetsDir)/SAM_E/XML/ATSAME70J20B_Registers.xml

DeviceSystemFile=$(TargetsDir)/SAM_E/CMSIS/source/system_SAME70.c

DeviceVectorsFile=$(TargetsDir)/SAM_E/Source/ATSAME70J20B_Vectors.s

DeviceFamily=SAM E
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ATSAME70J21
Device Details

CMSIS Header File $(TargetsDir)/SAM_E/CMSIS/same70a/include/sam.h

CMSIS Include Path $(TargetsDir)/SAM_E/CMSIS/same70a/include

CMSIS System File $(TargetsDir)/SAM_E/CMSIS/source/system_SAME70.c

Family SAM E

Loader File $(TargetsDir)/SAM_E/Loader/SAME70_Loader.elf

Memory Map File
$(TargetsDir)/SAM_E/XML/
ATSAME70J21_MemoryMap.xml

Register Definition File
$(TargetsDir)/SAM_E/XML/
ATSAME70J21_Registers.xml

Vectors File $(TargetsDir)/SAM_E/Source/ATSAME70J21_Vectors.s

Preprocessor Definitions

ARM_MATH_CM7

__SAME70J21__

__SAM_E_FAMILY

Memory Segments

FLASH 0x00400000 - 0x005FFFFF

RAM 0x20400000 - 0x2045FFFF

Project Macros

DeviceIncludePath=$(TargetsDir)/SAM_E/CMSIS/same70a/include

DeviceHeaderFile=$(TargetsDir)/SAM_E/CMSIS/same70a/include/sam.h

DeviceLoaderFile=$(TargetsDir)/SAM_E/Loader/SAME70_Loader.elf

DeviceRegisterDefinitionFile=$(TargetsDir)/SAM_E/XML/ATSAME70J21_Registers.xml

DeviceSystemFile=$(TargetsDir)/SAM_E/CMSIS/source/system_SAME70.c

DeviceVectorsFile=$(TargetsDir)/SAM_E/Source/ATSAME70J21_Vectors.s

DeviceFamily=SAM E
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ATSAME70J21B
Device Details

CMSIS Header File $(TargetsDir)/SAM_E/CMSIS/same70b/include/sam.h

CMSIS Include Path $(TargetsDir)/SAM_E/CMSIS/same70b/include

CMSIS System File $(TargetsDir)/SAM_E/CMSIS/source/system_SAME70.c

Family SAM E

Loader File $(TargetsDir)/SAM_E/Loader/SAME70_Loader.elf

Memory Map File
$(TargetsDir)/SAM_E/XML/
ATSAME70J21B_MemoryMap.xml

Register Definition File
$(TargetsDir)/SAM_E/XML/
ATSAME70J21B_Registers.xml

Vectors File $(TargetsDir)/SAM_E/Source/ATSAME70J21B_Vectors.s

Preprocessor Definitions

ARM_MATH_CM7

__SAME70J21B__

__SAM_E_FAMILY

Memory Segments

FLASH 0x00400000 - 0x005FFFFF

RAM 0x20400000 - 0x2045FFFF

Project Macros

DeviceIncludePath=$(TargetsDir)/SAM_E/CMSIS/same70b/include

DeviceHeaderFile=$(TargetsDir)/SAM_E/CMSIS/same70b/include/sam.h

DeviceLoaderFile=$(TargetsDir)/SAM_E/Loader/SAME70_Loader.elf

DeviceRegisterDefinitionFile=$(TargetsDir)/SAM_E/XML/ATSAME70J21B_Registers.xml

DeviceSystemFile=$(TargetsDir)/SAM_E/CMSIS/source/system_SAME70.c

DeviceVectorsFile=$(TargetsDir)/SAM_E/Source/ATSAME70J21B_Vectors.s

DeviceFamily=SAM E
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ATSAME70N19
Device Details

CMSIS Header File $(TargetsDir)/SAM_E/CMSIS/same70a/include/sam.h

CMSIS Include Path $(TargetsDir)/SAM_E/CMSIS/same70a/include

CMSIS System File $(TargetsDir)/SAM_E/CMSIS/source/system_SAME70.c

Family SAM E

Loader File $(TargetsDir)/SAM_E/Loader/SAME70_Loader.elf

Memory Map File
$(TargetsDir)/SAM_E/XML/
ATSAME70N19_MemoryMap.xml

Register Definition File
$(TargetsDir)/SAM_E/XML/
ATSAME70N19_Registers.xml

Vectors File $(TargetsDir)/SAM_E/Source/ATSAME70N19_Vectors.s

Preprocessor Definitions

ARM_MATH_CM7

__SAME70N19__

__SAM_E_FAMILY

Memory Segments

FLASH 0x00400000 - 0x0047FFFF

RAM 0x20400000 - 0x2043FFFF

Project Macros

DeviceIncludePath=$(TargetsDir)/SAM_E/CMSIS/same70a/include

DeviceHeaderFile=$(TargetsDir)/SAM_E/CMSIS/same70a/include/sam.h

DeviceLoaderFile=$(TargetsDir)/SAM_E/Loader/SAME70_Loader.elf

DeviceRegisterDefinitionFile=$(TargetsDir)/SAM_E/XML/ATSAME70N19_Registers.xml

DeviceSystemFile=$(TargetsDir)/SAM_E/CMSIS/source/system_SAME70.c

DeviceVectorsFile=$(TargetsDir)/SAM_E/Source/ATSAME70N19_Vectors.s

DeviceFamily=SAM E
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ATSAME70N19B
Device Details

CMSIS Header File $(TargetsDir)/SAM_E/CMSIS/same70b/include/sam.h

CMSIS Include Path $(TargetsDir)/SAM_E/CMSIS/same70b/include

CMSIS System File $(TargetsDir)/SAM_E/CMSIS/source/system_SAME70.c

Family SAM E

Loader File $(TargetsDir)/SAM_E/Loader/SAME70_Loader.elf

Memory Map File
$(TargetsDir)/SAM_E/XML/
ATSAME70N19B_MemoryMap.xml

Register Definition File
$(TargetsDir)/SAM_E/XML/
ATSAME70N19B_Registers.xml

Vectors File
$(TargetsDir)/SAM_E/Source/
ATSAME70N19B_Vectors.s

Preprocessor Definitions

ARM_MATH_CM7

__SAME70N19B__

__SAM_E_FAMILY

Memory Segments

FLASH 0x00400000 - 0x0047FFFF

RAM 0x20400000 - 0x2043FFFF

Project Macros

DeviceIncludePath=$(TargetsDir)/SAM_E/CMSIS/same70b/include

DeviceHeaderFile=$(TargetsDir)/SAM_E/CMSIS/same70b/include/sam.h

DeviceLoaderFile=$(TargetsDir)/SAM_E/Loader/SAME70_Loader.elf

DeviceRegisterDefinitionFile=$(TargetsDir)/SAM_E/XML/ATSAME70N19B_Registers.xml

DeviceSystemFile=$(TargetsDir)/SAM_E/CMSIS/source/system_SAME70.c

DeviceVectorsFile=$(TargetsDir)/SAM_E/Source/ATSAME70N19B_Vectors.s

DeviceFamily=SAM E
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ATSAME70N20
Device Details

CMSIS Header File $(TargetsDir)/SAM_E/CMSIS/same70a/include/sam.h

CMSIS Include Path $(TargetsDir)/SAM_E/CMSIS/same70a/include

CMSIS System File $(TargetsDir)/SAM_E/CMSIS/source/system_SAME70.c

Family SAM E

Loader File $(TargetsDir)/SAM_E/Loader/SAME70_Loader.elf

Memory Map File
$(TargetsDir)/SAM_E/XML/
ATSAME70N20_MemoryMap.xml

Register Definition File
$(TargetsDir)/SAM_E/XML/
ATSAME70N20_Registers.xml

Vectors File $(TargetsDir)/SAM_E/Source/ATSAME70N20_Vectors.s

Preprocessor Definitions

ARM_MATH_CM7

__SAME70N20__

__SAM_E_FAMILY

Memory Segments

FLASH 0x00400000 - 0x004FFFFF

RAM 0x20400000 - 0x2045FFFF

Project Macros

DeviceIncludePath=$(TargetsDir)/SAM_E/CMSIS/same70a/include

DeviceHeaderFile=$(TargetsDir)/SAM_E/CMSIS/same70a/include/sam.h

DeviceLoaderFile=$(TargetsDir)/SAM_E/Loader/SAME70_Loader.elf

DeviceRegisterDefinitionFile=$(TargetsDir)/SAM_E/XML/ATSAME70N20_Registers.xml

DeviceSystemFile=$(TargetsDir)/SAM_E/CMSIS/source/system_SAME70.c

DeviceVectorsFile=$(TargetsDir)/SAM_E/Source/ATSAME70N20_Vectors.s

DeviceFamily=SAM E
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ATSAME70N20B
Device Details

CMSIS Header File $(TargetsDir)/SAM_E/CMSIS/same70b/include/sam.h

CMSIS Include Path $(TargetsDir)/SAM_E/CMSIS/same70b/include

CMSIS System File $(TargetsDir)/SAM_E/CMSIS/source/system_SAME70.c

Family SAM E

Loader File $(TargetsDir)/SAM_E/Loader/SAME70_Loader.elf

Memory Map File
$(TargetsDir)/SAM_E/XML/
ATSAME70N20B_MemoryMap.xml

Register Definition File
$(TargetsDir)/SAM_E/XML/
ATSAME70N20B_Registers.xml

Vectors File
$(TargetsDir)/SAM_E/Source/
ATSAME70N20B_Vectors.s

Preprocessor Definitions

ARM_MATH_CM7

__SAME70N20B__

__SAM_E_FAMILY

Memory Segments

FLASH 0x00400000 - 0x004FFFFF

RAM 0x20400000 - 0x2045FFFF

Project Macros

DeviceIncludePath=$(TargetsDir)/SAM_E/CMSIS/same70b/include

DeviceHeaderFile=$(TargetsDir)/SAM_E/CMSIS/same70b/include/sam.h

DeviceLoaderFile=$(TargetsDir)/SAM_E/Loader/SAME70_Loader.elf

DeviceRegisterDefinitionFile=$(TargetsDir)/SAM_E/XML/ATSAME70N20B_Registers.xml

DeviceSystemFile=$(TargetsDir)/SAM_E/CMSIS/source/system_SAME70.c

DeviceVectorsFile=$(TargetsDir)/SAM_E/Source/ATSAME70N20B_Vectors.s

DeviceFamily=SAM E
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ATSAME70N21
Device Details

CMSIS Header File $(TargetsDir)/SAM_E/CMSIS/same70a/include/sam.h

CMSIS Include Path $(TargetsDir)/SAM_E/CMSIS/same70a/include

CMSIS System File $(TargetsDir)/SAM_E/CMSIS/source/system_SAME70.c

Family SAM E

Loader File $(TargetsDir)/SAM_E/Loader/SAME70_Loader.elf

Memory Map File
$(TargetsDir)/SAM_E/XML/
ATSAME70N21_MemoryMap.xml

Register Definition File
$(TargetsDir)/SAM_E/XML/
ATSAME70N21_Registers.xml

Vectors File $(TargetsDir)/SAM_E/Source/ATSAME70N21_Vectors.s

Preprocessor Definitions

ARM_MATH_CM7

__SAME70N21__

__SAM_E_FAMILY

Memory Segments

FLASH 0x00400000 - 0x005FFFFF

RAM 0x20400000 - 0x2045FFFF

Project Macros

DeviceIncludePath=$(TargetsDir)/SAM_E/CMSIS/same70a/include

DeviceHeaderFile=$(TargetsDir)/SAM_E/CMSIS/same70a/include/sam.h

DeviceLoaderFile=$(TargetsDir)/SAM_E/Loader/SAME70_Loader.elf

DeviceRegisterDefinitionFile=$(TargetsDir)/SAM_E/XML/ATSAME70N21_Registers.xml

DeviceSystemFile=$(TargetsDir)/SAM_E/CMSIS/source/system_SAME70.c

DeviceVectorsFile=$(TargetsDir)/SAM_E/Source/ATSAME70N21_Vectors.s

DeviceFamily=SAM E



SAM E CPU Support Package Guide SAM E Support Package

24

ATSAME70N21B
Device Details

CMSIS Header File $(TargetsDir)/SAM_E/CMSIS/same70b/include/sam.h

CMSIS Include Path $(TargetsDir)/SAM_E/CMSIS/same70b/include

CMSIS System File $(TargetsDir)/SAM_E/CMSIS/source/system_SAME70.c

Family SAM E

Loader File $(TargetsDir)/SAM_E/Loader/SAME70_Loader.elf

Memory Map File
$(TargetsDir)/SAM_E/XML/
ATSAME70N21B_MemoryMap.xml

Register Definition File
$(TargetsDir)/SAM_E/XML/
ATSAME70N21B_Registers.xml

Vectors File
$(TargetsDir)/SAM_E/Source/
ATSAME70N21B_Vectors.s

Preprocessor Definitions

ARM_MATH_CM7

__SAME70N21B__

__SAM_E_FAMILY

Memory Segments

FLASH 0x00400000 - 0x005FFFFF

RAM 0x20400000 - 0x2045FFFF

Project Macros

DeviceIncludePath=$(TargetsDir)/SAM_E/CMSIS/same70b/include

DeviceHeaderFile=$(TargetsDir)/SAM_E/CMSIS/same70b/include/sam.h

DeviceLoaderFile=$(TargetsDir)/SAM_E/Loader/SAME70_Loader.elf

DeviceRegisterDefinitionFile=$(TargetsDir)/SAM_E/XML/ATSAME70N21B_Registers.xml

DeviceSystemFile=$(TargetsDir)/SAM_E/CMSIS/source/system_SAME70.c

DeviceVectorsFile=$(TargetsDir)/SAM_E/Source/ATSAME70N21B_Vectors.s

DeviceFamily=SAM E
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ATSAME70Q19
Device Details

CMSIS Header File $(TargetsDir)/SAM_E/CMSIS/same70a/include/sam.h

CMSIS Include Path $(TargetsDir)/SAM_E/CMSIS/same70a/include

CMSIS System File $(TargetsDir)/SAM_E/CMSIS/source/system_SAME70.c

Family SAM E

Loader File $(TargetsDir)/SAM_E/Loader/SAME70_Loader.elf

Memory Map File
$(TargetsDir)/SAM_E/XML/
ATSAME70Q19_MemoryMap.xml

Register Definition File
$(TargetsDir)/SAM_E/XML/
ATSAME70Q19_Registers.xml

Vectors File $(TargetsDir)/SAM_E/Source/ATSAME70Q19_Vectors.s

Preprocessor Definitions

ARM_MATH_CM7

__SAME70Q19__

__SAM_E_FAMILY

Memory Segments

FLASH 0x00400000 - 0x0047FFFF

RAM 0x20400000 - 0x2043FFFF

Project Macros

DeviceIncludePath=$(TargetsDir)/SAM_E/CMSIS/same70a/include

DeviceHeaderFile=$(TargetsDir)/SAM_E/CMSIS/same70a/include/sam.h

DeviceLoaderFile=$(TargetsDir)/SAM_E/Loader/SAME70_Loader.elf

DeviceRegisterDefinitionFile=$(TargetsDir)/SAM_E/XML/ATSAME70Q19_Registers.xml

DeviceSystemFile=$(TargetsDir)/SAM_E/CMSIS/source/system_SAME70.c

DeviceVectorsFile=$(TargetsDir)/SAM_E/Source/ATSAME70Q19_Vectors.s

DeviceFamily=SAM E
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ATSAME70Q19B
Device Details

CMSIS Header File $(TargetsDir)/SAM_E/CMSIS/same70b/include/sam.h

CMSIS Include Path $(TargetsDir)/SAM_E/CMSIS/same70b/include

CMSIS System File $(TargetsDir)/SAM_E/CMSIS/source/system_SAME70.c

Family SAM E

Loader File $(TargetsDir)/SAM_E/Loader/SAME70_Loader.elf

Memory Map File
$(TargetsDir)/SAM_E/XML/
ATSAME70Q19B_MemoryMap.xml

Register Definition File
$(TargetsDir)/SAM_E/XML/
ATSAME70Q19B_Registers.xml

Vectors File
$(TargetsDir)/SAM_E/Source/
ATSAME70Q19B_Vectors.s

Preprocessor Definitions

ARM_MATH_CM7

__SAME70Q19B__

__SAM_E_FAMILY

Memory Segments

FLASH 0x00400000 - 0x0047FFFF

RAM 0x20400000 - 0x2043FFFF

Project Macros

DeviceIncludePath=$(TargetsDir)/SAM_E/CMSIS/same70b/include

DeviceHeaderFile=$(TargetsDir)/SAM_E/CMSIS/same70b/include/sam.h

DeviceLoaderFile=$(TargetsDir)/SAM_E/Loader/SAME70_Loader.elf

DeviceRegisterDefinitionFile=$(TargetsDir)/SAM_E/XML/ATSAME70Q19B_Registers.xml

DeviceSystemFile=$(TargetsDir)/SAM_E/CMSIS/source/system_SAME70.c

DeviceVectorsFile=$(TargetsDir)/SAM_E/Source/ATSAME70Q19B_Vectors.s

DeviceFamily=SAM E
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ATSAME70Q20
Device Details

CMSIS Header File $(TargetsDir)/SAM_E/CMSIS/same70a/include/sam.h

CMSIS Include Path $(TargetsDir)/SAM_E/CMSIS/same70a/include

CMSIS System File $(TargetsDir)/SAM_E/CMSIS/source/system_SAME70.c

Family SAM E

Loader File $(TargetsDir)/SAM_E/Loader/SAME70_Loader.elf

Memory Map File
$(TargetsDir)/SAM_E/XML/
ATSAME70Q20_MemoryMap.xml

Register Definition File
$(TargetsDir)/SAM_E/XML/
ATSAME70Q20_Registers.xml

Vectors File $(TargetsDir)/SAM_E/Source/ATSAME70Q20_Vectors.s

Preprocessor Definitions

ARM_MATH_CM7

__SAME70Q20__

__SAM_E_FAMILY

Memory Segments

FLASH 0x00400000 - 0x004FFFFF

RAM 0x20400000 - 0x2045FFFF

Project Macros

DeviceIncludePath=$(TargetsDir)/SAM_E/CMSIS/same70a/include

DeviceHeaderFile=$(TargetsDir)/SAM_E/CMSIS/same70a/include/sam.h

DeviceLoaderFile=$(TargetsDir)/SAM_E/Loader/SAME70_Loader.elf

DeviceRegisterDefinitionFile=$(TargetsDir)/SAM_E/XML/ATSAME70Q20_Registers.xml

DeviceSystemFile=$(TargetsDir)/SAM_E/CMSIS/source/system_SAME70.c

DeviceVectorsFile=$(TargetsDir)/SAM_E/Source/ATSAME70Q20_Vectors.s

DeviceFamily=SAM E
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ATSAME70Q20B
Device Details

CMSIS Header File $(TargetsDir)/SAM_E/CMSIS/same70b/include/sam.h

CMSIS Include Path $(TargetsDir)/SAM_E/CMSIS/same70b/include

CMSIS System File $(TargetsDir)/SAM_E/CMSIS/source/system_SAME70.c

Family SAM E

Loader File $(TargetsDir)/SAM_E/Loader/SAME70_Loader.elf

Memory Map File
$(TargetsDir)/SAM_E/XML/
ATSAME70Q20B_MemoryMap.xml

Register Definition File
$(TargetsDir)/SAM_E/XML/
ATSAME70Q20B_Registers.xml

Vectors File
$(TargetsDir)/SAM_E/Source/
ATSAME70Q20B_Vectors.s

Preprocessor Definitions

ARM_MATH_CM7

__SAME70Q20B__

__SAM_E_FAMILY

Memory Segments

FLASH 0x00400000 - 0x004FFFFF

RAM 0x20400000 - 0x2045FFFF

Project Macros

DeviceIncludePath=$(TargetsDir)/SAM_E/CMSIS/same70b/include

DeviceHeaderFile=$(TargetsDir)/SAM_E/CMSIS/same70b/include/sam.h

DeviceLoaderFile=$(TargetsDir)/SAM_E/Loader/SAME70_Loader.elf

DeviceRegisterDefinitionFile=$(TargetsDir)/SAM_E/XML/ATSAME70Q20B_Registers.xml

DeviceSystemFile=$(TargetsDir)/SAM_E/CMSIS/source/system_SAME70.c

DeviceVectorsFile=$(TargetsDir)/SAM_E/Source/ATSAME70Q20B_Vectors.s

DeviceFamily=SAM E
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ATSAME70Q21
Device Details

CMSIS Header File $(TargetsDir)/SAM_E/CMSIS/same70a/include/sam.h

CMSIS Include Path $(TargetsDir)/SAM_E/CMSIS/same70a/include

CMSIS System File $(TargetsDir)/SAM_E/CMSIS/source/system_SAME70.c

Family SAM E

Loader File $(TargetsDir)/SAM_E/Loader/SAME70_Loader.elf

Memory Map File
$(TargetsDir)/SAM_E/XML/
ATSAME70Q21_MemoryMap.xml

Register Definition File
$(TargetsDir)/SAM_E/XML/
ATSAME70Q21_Registers.xml

Vectors File $(TargetsDir)/SAM_E/Source/ATSAME70Q21_Vectors.s

Preprocessor Definitions

ARM_MATH_CM7

__SAME70Q21__

__SAM_E_FAMILY

Memory Segments

FLASH 0x00400000 - 0x005FFFFF

RAM 0x20400000 - 0x2045FFFF

Project Macros

DeviceIncludePath=$(TargetsDir)/SAM_E/CMSIS/same70a/include

DeviceHeaderFile=$(TargetsDir)/SAM_E/CMSIS/same70a/include/sam.h

DeviceLoaderFile=$(TargetsDir)/SAM_E/Loader/SAME70_Loader.elf

DeviceRegisterDefinitionFile=$(TargetsDir)/SAM_E/XML/ATSAME70Q21_Registers.xml

DeviceSystemFile=$(TargetsDir)/SAM_E/CMSIS/source/system_SAME70.c

DeviceVectorsFile=$(TargetsDir)/SAM_E/Source/ATSAME70Q21_Vectors.s

DeviceFamily=SAM E
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ATSAME70Q21B
Device Details

CMSIS Header File $(TargetsDir)/SAM_E/CMSIS/same70b/include/sam.h

CMSIS Include Path $(TargetsDir)/SAM_E/CMSIS/same70b/include

CMSIS System File $(TargetsDir)/SAM_E/CMSIS/source/system_SAME70.c

Family SAM E

Loader File $(TargetsDir)/SAM_E/Loader/SAME70_Loader.elf

Memory Map File
$(TargetsDir)/SAM_E/XML/
ATSAME70Q21B_MemoryMap.xml

Register Definition File
$(TargetsDir)/SAM_E/XML/
ATSAME70Q21B_Registers.xml

Vectors File
$(TargetsDir)/SAM_E/Source/
ATSAME70Q21B_Vectors.s

Preprocessor Definitions

ARM_MATH_CM7

__SAME70Q21B__

__SAM_E_FAMILY

Memory Segments

FLASH 0x00400000 - 0x005FFFFF

RAM 0x20400000 - 0x2045FFFF

Project Macros

DeviceIncludePath=$(TargetsDir)/SAM_E/CMSIS/same70b/include

DeviceHeaderFile=$(TargetsDir)/SAM_E/CMSIS/same70b/include/sam.h

DeviceLoaderFile=$(TargetsDir)/SAM_E/Loader/SAME70_Loader.elf

DeviceRegisterDefinitionFile=$(TargetsDir)/SAM_E/XML/ATSAME70Q21B_Registers.xml

DeviceSystemFile=$(TargetsDir)/SAM_E/CMSIS/source/system_SAME70.c

DeviceVectorsFile=$(TargetsDir)/SAM_E/Source/ATSAME70Q21B_Vectors.s

DeviceFamily=SAM E
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Troubleshooting

On-Chip RC Oscillator

If your program doesn't start up and you are using a board without an external oscillator, set the Build Options >

Use On-Chip RC Oscillator project property to Yes.

TCM

Code and data can be placed in TCM memory either by setting the Section Placement project property to one of

the TCM configurations or by placing code/data in the TCM program sections (.bss_tcm, .data_tcm, .rodata_tcm

and .text_tcm).

For this to work, the device must also be configured to enable TCM memory by setting the Build Options > TCM

Configuration project property. Failure to do this will result in ITCM/DTCM memory segment overflow errors

from the linker.
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